3

I did a complete fresh installation with Xubuntu 16.04.1 LTS. Unfortunately, my HDMI-display does not work. Everything fine using the live-usb. But after reboot and first boot of the fresh installed system, the HDMI-display says 'No signal' and goes standby. I've checked a few things. The system, as well as the live-usb, uses the nouveau-driver for my Nvidia GeForce GT 640.

First, I tried using the proprietary driver using the "additional driver"-application.
-> crashed the whole system.
Then, I tried using the proprietary driver nvidia-304 using the command line.
-> crashed the whole system.

Of course, I tried to ensure that the display is working fine. It goes with the live-usb, as mentioned before, and it goes with another laptop (also running the same live-usb).

After searching the internet for terms like "hdmi does not work xubuntu" or "xubuntu nvidia driver" I checked some hardware data: Live-usb and my PC (after installation) are using the same nouveau-driver. The only difference I found is the kernel. Live-usb is using 4.4.0-31-generic and the installed system is using 4.4.0-64-generic.

There was no problem under Xubuntu 14.04 LTS.

The system detects the HDMI-display correctly, but don't send it any signal. When I open the display-settings everything looks fine. All displays are there and can be managed.

Update: After the fourth or fifth re-installation the HDMI-display works now. But after the display is going off, because of energy-savings, its not coming back on-line after waking it up.

Some facts about my hardware:
I'm using a dual-display setup with two Acer G246HL Bbid (One connected via DVI and the other connected via HDMI). The graphics is Nvidia GeForce GT 640.

lspci -v | perl -ne '/VGA/../^$/ and /VGA|Kern/ and print' gets me

01:00.0 VGA compatible controller: NVIDIA Corporation GK107 [GeForce GT 640] (rev) (prog-if 00 [VGA controller])
        Kernel driver in use: nouveau
        Kernel modules: nvidiafb, nouveau

And uname -r gets me

4.4.0-31-generic

on live-usb and

4.4.0-64-generic

on fresh installed system.

xrandr gets me

HDMI-1 connected 1920x1080+1920+0 (normal left inverted right x axis yaxis) 531mm x 299mm

followed by a list of available resolutions.
When I do apt list --installed | grep nouveau it gets me

libdrm-nouveau2/xenial-updates,now 2.4.70-1~ubuntu16.04.1 amd64 [installed]
xserver-xorg-video-nouveau/xenial,now 1:1.0.12-1build2 amd64 [installed]

Doing it with grep nvidia gets no result.

I'm using Xubuntu 16.04.1 LTS 64bit-version with LVM-encryption.

What I tried before:
Ubuntu 16.04LTS extended display not working
https:// wiki.ubuntuusers.de/Grafikkarten/Nvidia/nvidia/
http:// askubuntu.com/questions/806720/hdmi-connected-monitor-not-working-after-upgrade-from-14-04-to-16-04
https:// bugs.launchpad.net/ubuntu/+source/xorg/+bug/1574005

I've considered to install another kernel (4.4.25) using http://linuxdaddy.com/blog/install-kernel-4-4-on-ubuntu/. But didn't do it yet.

Does anyone knows a solution for that kind problem in general? At the moment I will prevent my display from going in energy-savings-caused standby to have a little workaround.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.