2

In a document like this I have underlined and strike through text. Originally, the document was created by Microsoft word. Currently this text is also colored - either blue or some yellow, depending on how I call Libreoffice.

When printed to a PDF, the blue color remains.

How can I change the document such that the color is removed? Not only for one printing, but generally in the document such that this document can be printed without colors by anyone.

Help suggested to select "Print black", but I cannot find this. (I am using 3.5.7.2 - which is the latest on 12.04.5 LTS)

  • Not the proper place to post, as this is a question about LibreOffice. – Muaad ElSharif Feb 27 '17 at 12:55
  • 3
    @MuaadElSharif The question is on topic, as are all questions relating to software running on Ubuntu. – Bruni Feb 27 '17 at 12:56
  • @MuaadElSharif: What do you suggest? – false Feb 27 '17 at 13:10
  • Delete all the changes and change the text manually, I did it and it worked. @false – Muaad ElSharif Feb 27 '17 at 14:38
  • @MuaadElSharif: The original document is 7 pages ... – false Feb 27 '17 at 14:49
2

Go to Tools -> Options -> LibreOffice Writer -> Changes and set all colors to black.

changes

  • Is this information stored in the actual document? At least there is no way to save the document thereafter, so this change was not registered as a change to the document. I saved it anyway - need to check with a W-in-dow system... – false Feb 27 '17 at 14:46
  • Apparently not, which in my opinion is for the best. Typically other people would expect any changes to be highlighted when viewed in LibreOffice. To remove the colors for easy printing, give other people the PDF file. Or tell them how to change their settings. – Jim K Feb 27 '17 at 15:29
1

Well, in your document, the underlined text and the strike through text are both Reviews of the document. So, if you want to see them as a normal text you must either accept or reject them (for example, if you accept every strike through text will be removed and every underlined text will be added).

Accept/Reject changes in a LibreOffice Writer Document

1

At the moment, there is no way to completely remove colour from your document in LibreOffice. That is to say, there is no way that whatever you add into the document, it will always show up in black. You do have a couple options, however:

1. Change all text color to black.

Begin by selecting all the text in the document. (Ctrl + a) On your toolbar, you should have an icon that looks something like this:

enter image description here

Click on it, and it gives you a drop down that looks something like this:

enter image description here

Select the black colour. This will turn all the text in your document black, however, as I said above, it will not prevent new text from having another colour: you will have to repeat the process every time you add something with another colour.

2. Eliminate colour when exporting to pdf.

Go to your menus: Tools > Options. In the window that pops up, go to LibreOffice Writer/Web > Print. You should see something like this:

enter image description here

Check the Print text in Black box, and you're done. Now when you export as PDF, it should export it all in black.

Hope it helps!

  • For your method 1: I can change the color of the remaining text that way, but the insert-underline and delete-strikethrough is still in the same blue. – false Feb 27 '17 at 13:47
  • @false, you'll have to change the default colours in Styles & Formatting. I believe it's F11 to access them. – anonymous2 Feb 27 '17 at 13:55
  • I was there, but I do not find anything appropriate. – false Feb 27 '17 at 14:04
  • @false Hmm... In that case, you may have to go under LibreOffice Writer > Changes in the dialog I posted a picture of. I would personally change the colours to "[None]", since this will remove the colour from the styles listed. – anonymous2 Feb 27 '17 at 14:41
  • Seems I searched it in the wrong place. See another answer for how this continued. – false Feb 27 '17 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.