0

"Keefox was not allowed to connect probably because you entered a connection password incorrectly" error appears when KeePass2 Portable is left open for some time. The notification prevent me from using the Firefox normally.

To stop Keefox from displaying the error notification, i try to close the KeePass program each time after using it to login into a website and reopen it when there is need to log in to another website.

*Updates on 6 March 2017: The bug can be temporarily ended by quiting the KeePass application

Following Options are set in the program as advised by luckyrat (developer of the Keepass program):

KeePassHttp Options: Always allow access to entries

KeeFox (RPCPlugin) Options: Connection Security tab set to "medium" for both "KeePass Security Level" and "Minimum acceptable client security level".

Authorised Client tab have the "connected" tick missing.

KeePass Options: Default settings are kept,for e.g.:Security tab have only the setting "Clipboard autoclear time(seconds) :12"

I look forward to suggestions to help make firefox browsing secure and productive.

The logtext is as follows (a trimmed down version) from Feb 25 to Feb 27:
"Sat Feb 25 2017 16:30:16 GMT+0800 (SGT):Logging system initialised at Sat Feb 25 2017 16:30:16 GMT+0800 (SGT)

Sat Feb 25 2017 16:33:28 GMT+0800 (SGT):WARN: KeeFox was not allowed to connect, probably because you entered the connection password incorrectly. Further info may follow: Keys do not match

Sat Feb 25 2017 16:45:05 GMT+0800 (SGT):WARN: KeeFox was not allowed to connect, probably because you entered the connection password incorrectly. Further info may follow: Stored key not found - Caused by changed Firefox profile or KeePass instance; changed OS user credentials; or KeePass config file may be corrupt

Sat Feb 25 2017 16:46:40 GMT+0800 (SGT):WARN: KeeFox was not allowed to connect, probably because you entered the connection password incorrectly. Further info may follow: Stored key not found - Caused by changed Firefox profile or KeePass instance; changed OS user credentials; or KeePass config file may be corrupt

Sat Feb 25 2017 16:49:14 GMT+0800 (SGT):Logging system initialised at Sat Feb 25 2017 16:49:14 GMT+0800 (SGT)

Sat Feb 25 2017 18:26:41 GMT+0800 (SGT):WARN: An error occurred when processing the result callback for JSON-RPC object id 180: TypeError: keefox_win.requestorMap[resultWrapper.id].messageManager is undefined

Sun Feb 26 2017 12:21:19 GMT+0800 (SGT):Logging system initialised at Sun Feb 26 2017 12:21:19 GMT+0800 (SGT)

Sun Feb 26 2017 16:41:14 GMT+0800 (SGT):WARN: KeeFox was not allowed to connect, probably because you entered the connection password incorrectly. Further info may follow: Keys do not match

Sun Feb 26 2017 16:45:32 GMT+0800 (SGT):WARN: KeeFox was not allowed to connect, probably because you entered the connection password incorrectly. Further info may follow: Keys do not match

Mon Feb 27 2017 18:19:14 GMT+0800 (SGT):Logging system initialised at Mon Feb 27 2017 18:19:14 GMT+0800 (SGT)

Mon Feb 27 2017 17:35:58 GMT+0800 (SGT):WARN: KeeFox was not allowed to connect, probably because you entered the connection password incorrectly. Further info may follow: Keys do not match

Mon Feb 27 2017 18:01:50 GMT+0800 (SGT):WARN: KeeFox was not allowed to connect, probably because you entered the connection password incorrectly. Further info may follow: Keys do not match /"

0

Quoting the solution proposed by @g1ps on the github issues page (see the linkgithub for KeeFox

Blockquote

"In case anyone else has the same issue as me, I'm reporting what I found here. My problem was that I'd changed the names of some groups in Keepass, including Keepass's home group. After trying a number of times over a period of several months, I finally stumbled across a reference to this and reassiged the start-up group. Normal functionality was restored immediately. I knew that Keefox was connecting because I could log in and other factors worked, it was just not staying logged in or matching log-ins. The details of how to correct this situation are here:

https://github.com/luckyrat/KeeFox/wiki/en-|-Using-KeeFox

under "Home group".

The error no longer recurs for now. Hence, setting the KeePass category, containing the Firefox access key to Keepass, as KeeFox Start Group may be the solution as explained in the wiki link.

I hoped this solution helps anyone facing this problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.