3

Ubuntu 16.10 on my Lenovo G500 is booting in emergency mode after upgrade from 16.04. The previous upgrades worked just fine (14.04 to 15.04 to 15.10 and so on).

Things I already tried:

  1. Attempt 1:

    • Booted using Live Ubuntu 16.04 DVD.
    • Started a terminal and did a file check on the my root partition i.e: e2fsck -pvf /dev/sda9

    • Rebooted from HDD

Result: Booted in emergency mode

  1. Attempt 2

    • Booted from Live Ubuntu 16.04 DVD

    • Did a tune2fs -l /dev/sda9 | grep -i check, turned out fsck was last performed in July 2016.

    • Mounted /dev/sda9 and created a file forcefsck in `/´ directory
    • Rebooted from HDD.

Result: Booted in emergency mode.

After rebooting the screen looks like this:

enter image description here

Tune2fs results look like this:

Tune2fs results

I am out of ideas.

Update

I did a fresh install of Ubuntu 16.10, with the contents in my $HOME directory intact. But I still do not know the exact reason, why it failed to boot.

11
  • Did you install that nasty Intel Video Driver for 16.04? You should be able to ppa-purge it, or install the 16.10 version of the driver. Ask if you need more info/help. – heynnema Feb 26 '17 at 17:26
  • @heynnema I did not install it explicitly but may be while upgrading it was done automatically I'm guessing. I just checked, is it the xserver-xorg-video-intel driver you mean? – Abel Tom Feb 26 '17 at 17:28
  • You would have had to explicitly installed the Intel Video driver at some point. The 16.10 upgrade wouldn't have done it. In your GRUB menu, go into edit mode and find the kernel/linux line that contains "splash quiet" and edit it so it says "splash quiet nomodeset" and see if you can boot fully. – heynnema Feb 26 '17 at 17:31
  • You could also see if you can find if the Intel driver has been installed by dpkg -l *intel* | grep ii and see if you find it. – heynnema Feb 26 '17 at 17:32
  • Yea i did a dpkg --list | grep intel previously to find that driver i mentioned, I found the line that says quiet splash $vt_handoff. Should I replace $vt_handoff with nomodeset. I have no idea what that is. – Abel Tom Feb 26 '17 at 17:37
3

Found a simple permanent solution. This worked for me on 16.04.2 LTS:

  1. In your GRUB menu, go into edit mode and find the kernel/linux line that contains "splash quiet" and replace $vt_handoff with nomodeset. You should now be able to boot properly.

  2. Edit the file /etc/grub.d/10_linux. Find the vt_handoff variable, around line 27 and change vt_handoff="1" to vt_handoff="0" and save the file.

  3. Finally:

    $ sudo update-grub
    
  4. Reboot

1
  • 1
    I had the same issue and your solution worked like a charm – ponach Nov 26 '17 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.