0

I recentyly got an Asus Zenbook UX501VW (FI127T), after a lot of troubles just to get Ubuntu installed, now I got the laptop to a decent state.

Now I have Ubuntu 16.10, kernel 4.8.0-39-generic.

I've realized that it doesn't seem to be using the NVIDIA graphics card, and I can't find how to switch to it.

I have both the NVIDIA and Intel Microcode drivers installed and active.

In 'About this Computer' I get:

Which says it's using the integrated Intel® HD Graphics 530 (Skylake GT2).

Also, output to

$ lspci -vk | grep VGA

I only get

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06) (prog-if 00 [VGA controller])

And also, if I open the NVIDIA X Server Settings, to try to change the graphics card in the Prime setting, I only get this:

Like it seems as there are options missing.

Any idea how to switch to the NVIDIA card?

1 Answer 1

2

Disable Secure Boot in BIOS and you will be able to switch to the Nvidia adapter.

The driver is disabled by Secure Boot.

1
  • Thanks! That seemed to solve it! Now the problem is that if I set the Intel GPU instead of the NVIDIA one I get the fan at max speed issue. I'll look how to solve it.
    – jonazla
    Feb 26, 2017 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.