I recently got a ThinkPad X260 with i7 processor, 16GB RAM, 1920x1080 resolution, and a 500GB Samsung SSD that I put in it. After spending some time distro hopping I have returned to the Canonical released variant of Ubuntu with Unity. Other distros all had one thing or another that would annoy me about it, but I am happy to report that Unity is largely free from those, with one minor issue that I hope can be rectified.

Chrome has a tendency to open off screen, just enough that the horizontal scrolling bar and the down arrow on the vertical are obscured. Furthermore, it opens leaving a gap between the top panel and the edge of the browser. Moving the browser up will reveal that the browser is sized to fit the screen vertically.

What I've noticed further is that the browser does not seem to hold it's position or size settings from close to close. It sometimes will, but the browser seems to gravitate towards the bottom of the screen with each instance of opening. A restart generally restores the half screen, off the bottom position.

I've tested by installing Chromium without syncing any settings or changing anything and found the same issue. Anyone know a solution?


5 Answers 5


Let me offer this fix I found, these steps are:

  1. use the key combination ALT+TAB till you are positioned on Chrome before continuing with the next step.

  2. Press Alt + Space: This opens the the "Window Menu".

  3. Choose "move" either by clicking on the option if you can see the menu, or by hitting the "M" key.

  4. Hit one of the "arrow" keys, the one with a direction opposite to where your browser window has gone (mine went to the right, so I hit the "left arrow" key) enough times until you can see enough of the browser to be able to drag it.

  5. Drag the browser to the desired position.

  6. Close the browser (this is important in order to ensure that this new position of the browser is saved and will be the position of the browser the next time you open it. Skipping this step means that the last saved position is "off screen". Should the browser close improperly, it will re-open in the last saved position, that is "off screen" and this procedure will need to be repeated.)

  7. Re-open you browser and proceed normally.

Source:- credits: Sunny Balanga


  • Not sure of #6--doesn't work in my case, however, #1, #2, #3 and #5 have allowed me to recuperate "dead" Chrome windows that have frequently plagued me now for over a year on Linux Mint (Ubuntu) with multiple workspaces. Commented Aug 2, 2022 at 20:49

There is no real method of fixing this. The best you can do is press CTRL + CMD (Windows) + Up Arrow every time. This will make it fit to the screen.


Use compizconfig-settings-manager to manage your windows placement.

From CCSM (click) Window Management -> (click) Place Windows -> (select) Smart.

There are other options in the Placement Mode dropdown for you to test and pick the best one for your taste. Cascade is one that will perform a similar resolution to Smart.

The Smart option is the default option. From the description in your message this isn't happening. The setting you see in CCSM might be overwritten or just corrupted. Using CCSM to change it and change it back will correctly ensure the setting is in effect.


If you're doing it in an Incognito mode, moving or resizing the Chrome window to the desired location (and closing it to save the new position) will not work. You'll have to do it on a normal window for it to work.

  • No. I never heard about this. Commented Mar 27, 2018 at 8:01

In my case it was one of the Chrome extensions that was causing the problem, I turned off all the Chrome extensions, and then turned them on one at a time and opened Chrome until I found the culprit (in my case it was the "Max Payback" extension which somehow uses what is called OpenResty). Now Google Chrome works well (and I turn this extension on only when I need it and then turn it back off).
I hope this is useful/helpful!

You must log in to answer this question.