3

So, I have installed a few versions of Ubuntu, 14.04, 15.10, 16.04.After that I've installed Linux Mint 18.1 just to come back at Ubuntu 16.04(with every try dual-boot Windows 10).

The reason why I've been through all these versions is because I've had unstable and very slow wireless connection(about 15x slower in comparison with Windows 10) no matter the version. I've tried what seemed to be working for other users, even if my problem wasn't exactly the same. I even tried upgrading to kernel 4.10 but the problem is still there.

Something interesting is, while I have Ubuntu/Linux Mint installed, when I switch to Windows 10 I have the same issue as mentioned. If I remove Ubuntu/Linux Mint the problem goes away and everything is back to normal.

Here's my wireless-script result: http://pastebin.com/YCGr8Xc1

I may add the fact that Windows 10 and Ubuntu are installed on separate partitions.

Thanks in advance!

0

It could be the same problem as I just had myself, so it's worth a try. My problem was a slow and unstable network connection, and occasionally it would disconnect.

To clarify, this is my network adapter, which seems to be exactly the same as the OP's:

$ lspci -nnk | grep -iA 2 '^[^[:space:]].*net'
01:00.0 Network controller [0280]: Qualcomm Atheros QCA9565 / AR9565 
Wireless Network Adapter [168c:0036] (rev 01)
    Subsystem: Lenovo QCA9565 / AR9565 Wireless Network Adapter [17aa:4026]
    Kernel driver in use: ath9k

The solution to my problem was to create a config file for the wireless driver:

sudo nano /etc/modprobe.d/ath9k.conf

add the following line:

options ath9k nohwcrypt=1

Make sure it's 100% identical and press Ctrl-X to exit, then Y to save. You can activate this option by rebooting, or if you're impatient you can load the module immediately:

sudo modprobe -r ath9k
sudo modprobe ath9k nohwcrypt=1

It's also possible to use these last two commands alone to test if this will solve the problem without modifying your system. The first one removes the module (unloads the driver), the second one inserts (loads) it again with the additional option.

My sources: How to resolve wireless disconnect problem in Atheros ath9k / How do I create a system file /etc/modprobe.d/ath9k.conf?

-2

You'll find the answer here on Ubuntu Forums

Blacklist the acer-wmi module:

echo "blacklist acer-wmi" | sudo tee -a /etc/modprobe.d/blacklist-acer-wmi.conf

It seems to have worked for me. As far as I am concerned, this problem has been around since 14.10. I hope it will eventually get fixed by the package maintainers.

  • 1
    The wireless network adapter in this question isn't soft-blocked like in the linked forum post, so I doubt the same solution applies here. -1 – David Foerster May 2 '17 at 2:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.