0

I use Lubuntu 16.10. When I run evince (from a shell), I get multiple error messages such as:

(evince:14128): Gtk-WARNING **: Theme parsing error: gtk-lubuntu.css:190:21: The :insensitive pseudo-class is deprecated. Use :disabled instead.

as well as:

(evince:17673): Gtk-WARNING **: Theme directory  imported-Humanity/192 of theme Lubuntu has no size field
(evince:17673): Gtk-WARNING **: Allocating size to EvSidebar 0x562e8f3ee310 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?

What can I do about these errors? They're annoying!

0

A partial answer:

For the first kind of errors (and some other CSS-syntax-change-related errors), you can edit /usr/share/themes/Lubuntu-default/gtk-3.0/ and make batch replacements of the deprecated pseudo-element names or property names with the up-to-date names. That avoids the vast majority of the errors on the console but not the last two that are listed in the question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.