In home directory ls shows the following:

terminal with ls

But let's look what is in Nautilus.

nautilus with home folder

I refreshed Nautilus many times. rm 1.1.c returns a error there is no such file in directory.

What's wrong?

  • 2
    Files ending with '~' are backup files (mostly from text editors). Nautilus doesn't seem to show them (maybe shows them if you modify some option(s)). To remove the files, you have to give the '~' as well; so rm 2.1.cpp~. There is no 1.1.cin your listing - maybe a typo? – ridgy Feb 24 '17 at 10:31
  • 1
    Possible duplicate of Prevent gedit from creating files with the '~' (tilde) suffix – mikewhatever Feb 24 '17 at 10:39

Nautilus has an option you can toggle by clicking on View to toggle Show Hidden Files files to on or off.

If you click the Show Hidden Files option you will see the hidden bakup files in Nautilus.

Files that end with the tilde (~) or begin with the dot (.) are hidden files.

Examples of hidden files:


Your ls command would show even more files if you used the -a argument.

Type in this:

$ ls -a

You will then see substantially more files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.