On Ubuntu 16.04 a machine I've installed VeraCrypt 1.19. When I'm trying to open an existing container I get the error:

"No such file or directory: dmsetup"


I created it on Windows 10 on a NTFS partition - but I don't think that's the problem.

I've tried the sudo apt-get install dmsetup thing, but that doesn't work.

Thanks in advance.

  • Welcome to Ask Ubuntu! Please edit your quesiton and add what you mean by "doesn't work". Can you give us the precise error message?
    – MadMike
    Feb 24 '17 at 7:48
  • After the dmsetup install, (1) I open VeraCrypt, (2) select a slot (drive in Win), (3) select the file container in NTFS partition, then hit MOUNT button. It just comes back with the same error.
    – dekker
    Feb 24 '17 at 8:07
  • This comment says to execute: sudo apt install exfat-fuse and exfat-utils dmsetup Does that help?
    – MadMike
    Feb 24 '17 at 8:13

I did

 sudo apt-get install dmsetup

according to this post. It started working after that.


I have the same problem and solved it. What I do is checking the "Do not use kernel cryptographic services" then it works.

go through with :veraCrypt >> Settings >> Default keyfiles > Tab-[System Integration]

[System Integration] > Kernel Services : "Do not use kernel cryptographic services" (<--- check it)

Good luck!

  • Works. But there is a warning Disabling the use of kernel cryptographic services can degrade performance. Oct 28 '17 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.