3

So I can connect to my Macbook's share via afp://ip/share, but that's about as far as I can get when it comes to accessing that directory. In order for me to pass this shared folder over to my VMs, I'd like to be able to mount this to a folder, and pass that folder over through to the VMs.

However, I can't seem to figure out how to get to this step. I can't connect to the share over SMB because of issues related to SMB signing, etc. that I spent a few hours on without success.

I tried using afpfs-ng but I can't even get it compiled and working correctly. I tried the following:

git clone https://github.com/simonvetter/afpfs-ng
cd afpfs-ng
./configure
make
sudo make install

and then tried to run it, but got an error:

$ mount_afp afp://192.168.1.13/Documents docs/
mount_afp: error while loading shared libraries: libafpclient.so.0: cannot open shared object file: No such file or directory

Any advice would be greatly appreciated.

3

I just ran into the same problem on Debian 8.7.

TL;DR: copy the compiled library file to a directory on the load path.

The details
I found where to copy it by looking at where the others were loaded from like this:

ldd $(which afp_client)

Which should show lines like this:
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f9b601e2000)

The missing library should have been built by the make command so I searched for it in the afpfs-ng directory like so:
find . -name libafpclient.so.0

Which was found here:
./lib/.libs/libafpclient.so.0

So I copied it like this:
cp lib/.libs/libafpclient.so.0 /lib/x86_64-linux-gnu/

There might be a more proper location for this to be copied to, but I'm working on a throw away VM and this made it work, so I didn't worry about it.

Update: I believe the proper place to put this would be /usr/local/lib/.

1
  • That fixed it for me! Now I can finally use this client. Thank you for the help! Apr 15 '17 at 22:38
0

I've just hit this on 16.04LTS; the make install step doesn't updated the shared library cache, you need to do it manually

sudo ldconfig

Info from Where does Ubuntu look for shared libraries?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.