1

I've upgraded from Ubuntu 14.04 to 16.04.2, recently. After having a failed upgrade, I reinstalled it using a DVD. Now after completing installation, when the DVD is ejected and I'm restarting, grub is coming up. I can't understand what I'm doing wrong. I followed the usual manual present at Ubuntu site. Please help.

output from lsblk:

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT

sr0 11:0 1 1.5G 0 rom /cdrom

loop0 7:0 0 1.4G 1 loop /rofs

sda 8:0 0 465.8G 0 disk

├─sda4 8:4 0 1M 0 part

├─sda2 8:2 0 40M 0 part

├─sda5 8:5 0 7.9G 0 part [SWAP]

├─sda3 8:3 0 3G 0 part

├─sda1 8:1 0 500M 0 part

└─sda6 8:6 0 454.4G 0 part

output of blkid

/dev/sda1: LABEL="ESP" UUID="FA37-2A18" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="ff682bf3-7817-4b03-98dd-3771979e9eb2"

/dev/sda2: LABEL="DIAGS" UUID="AAA2-6116" TYPE="vfat" PARTLABEL="Basic data partition" PARTUUID="6ccc7ecf-6835-4622-99ad-727d741dfb71"

/dev/sda3: LABEL="OS" UUID="3AA3-6F37" TYPE="vfat" PARTLABEL="Basic data partition" PARTUUID="25f16079-8a5c-460c-aebc-1065ee3498e5"

/dev/sda6: UUID="9ac4d432-65b5-4897-9a56-0ed86acb9803" TYPE="ext4" PARTUUID="82cbf0c4-bfd7-4b4e-8b18-fa752181e21f"

/dev/sr0: UUID="2017-02-15-21-44-13-00" LABEL="Ubuntu 16.04.2 LTS amd64" TYPE="iso9660" PTUUID="15e2543d" PTTYPE="dos"

output of grub-install

ubuntu@ubuntu:~$ sudo grub-install /dev/sda1

Installing for i386-pc platform.

grub-install: error: failed to get canonical path of `aufs'.

output after formatting hard drive (as obtained from live dvd boot)

ubuntu@ubuntu:~$ lsblk

NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT

sr0 11:0 1 1.5G 0 rom /cdrom

loop0 7:0 0 1.4G 1 loop /rofs

sda 8:0 0 465.8G 0 disk

├─sda2 8:2 0 1K 0 part

├─sda5 8:5 0 3.9G 0 part [SWAP]

└─sda1 8:1 0 461.9G 0 part

ubuntu@ubuntu:~$

  • When grub appears does it not start Ubuntu afterwards? – George Udosen Feb 23 '17 at 18:54
  • No, it doesn't. All I have is the grub2 terminal before me. – Debadri Chowdhury Feb 23 '17 at 18:59
1

Check EFI boot path. When booting with secureboot on custom EFI image should be:

EFI\ubuntu\shimx64.efi

Are you using HP computer? Those are having some problem with uefi boot. Hp bug:

https://bugs.launchpad.net/linuxmint/+bug/1309395

1

Final edit, for the straight to results solution.

Make sure you turn off UEFI completely in BIOS. i.e Use Legacy. If the option UEFI/Legacy appears on more than one BIOS menu, make sure Legacy is selected on all.

Boot into the Live CD

Do not reset or logout until you complete all of the steps or you will have to reinstall any program mentioned here as the Live CD will not save changes.

On the Live session install gparted, either through the GUI Software Center or with sudo apt-get install gparted

Open Gparted from the apps list and then select the hard drive on top right section.

With the drive selected delete all of the partitions on it by right clicking and selecting delete. Write those changes by clicking the check mark icon in the top menu

Once that is complete, select "Device" from the top text menu and "Create Partition Table"

When the pop up appears select ms-dos and write the changes. You can tell it to ignore any errors if you get any more popups.

Once that is done you have an MBR hard drive that is ready for Legacy booting.

Reboot and try installing Ubuntu again. Let the installer auto partition the hardrive, ,i.e Use Entire disk , with or without LVM.

  • Thanks m_krsic. But it says that I can't repair boot unless I'm on UEFI mode. I can't get Ubuntu to run on UEFI mode. All I have is the legacy ( via live DVD). Again, I've only Ubuntu installed on my system – Debadri Chowdhury Feb 23 '17 at 19:02
  • Are you dual booting ? – m_krsic Feb 23 '17 at 19:05
  • No. I've only Ubuntu – Debadri Chowdhury Feb 23 '17 at 19:06
  • Can you access your BIOS? Can you check if legacy/mbr mode is enabled? – m_krsic Feb 23 '17 at 19:12
  • Yeah. I can. I'm looking into it now. Should I change boot mode to UEFI? But then, options for booting from DVD and internal HDD are present in legacy. All I can do from UEFI is boot Ubuntu which is getting me stuck at grub2 – Debadri Chowdhury Feb 23 '17 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.