0

When I run snapcraft with this file :

name: hwapp-sample
version: 1.0
summary: sample app
description: sample app

binaries:
   hellodnx:
       exec: hwapp/hwapp.dll

parts:
   dnxsample:
       plugin: dump
       source: hwapp
       stage-packages:
       - libunwind8

I get this error :

Issues while validating snapcraft.yaml: Additional properties are not allowed ('binaries' was unexpected)

I have seen the binaries keyword being used on the internet here and here. This question does not have the answer.

1

The guides you link to are very old. The format & syntax of snapcraft.yaml has changed quite a bit since then. I would recommend using the official documentation which is located at https://snapcraft.io/docs/

For your specific issue, the format is as below:-

apps:
   hellodnx:
       command: hwapp/hwapp.dll

This is fully documented here:- https://snapcraft.io/docs/build-snaps/metadata

| improve this answer | |
  • The error went away. I now get the following error when I run hwapp-sample.hellodnx : "exec: /snap/hwapp-sample/x1/hwapp.dll: not found". Any suggestions? – Freek Nortier Feb 23 '17 at 3:46
  • Here is a link to the project : dropbox.com/sh/l13vcqr1dk0ix0i/AAA8MwXPTHY9cy94Z1P2DZrWa?dl=0 – Freek Nortier Feb 23 '17 at 3:53
  • Two issues here. One, the permissions on the binary files in ./hwapp are too restrictive, no execute permission for people other than the owner (which in snapd will be root). -rwxr--r-- 2 alan alan 4608 Feb 22 18:56 hwapp.dll – popey Feb 24 '17 at 12:42
  • Second issue, you're not bundling the necessary mono runtime needed by hwapp.dll, which you will need to do in the stage-packages section of your yaml. – popey Feb 24 '17 at 12:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.