2

I've made daily backups of my home folder on my laptop onto a hard drive connected to my raspi using Deja Dup 34.2 (I just looked the version number up and don't know when it was last updated.). My laptop runs Ubuntu 16.04 and my raspi runs Ubuntu 16.04 Mate. Communication between my laptop and my raspi happens via SSH.

Yesterday, I wanted to reset the contents of the folder ~/.electrum to an earlier version. (This question is not about recovering wallets, I still have my seeds, so no money is at risk, but I wanted to reset a specific wallet of mine to an earlier version.)

So I deleted the contents of ~/.electrum, went outside the folder, right-clicked it, and chose Revert to Previous Version.... After confirming the backup location and choosing a date in the past, Deja Dup tried to restore the files as usual. I reset folders to previous versions several times, already.

All but 2 files were successfully restored. Unfortunately, the 1 file I actually wanted to reset to a previous version (~/.electrum/wallets/default_wallet) (I didn't really care about the others, though it would have been nice to reset them too. 'm aware that one can set an individual file to a previous version.) could not be restored. The other file which couldn't be restored was a different wallet. The 2 other wallets were successfully restored. All 4 wallets were (previously and supposed to be) in ~/.electrum/wallets. A wallet in this case is merely a text file, a few kB in size.

The error message is as follows:

Could net restore the following files. Please make sure you are able to write to them.

/2.Filled Wallet
/default_wallet

The exact path varies depending on which folder I try to reset. To reproduce the error message, I just only deleted the contents of ~/.electrum/wallets and attempted to revert only that folder to a previous version.

I tried resetting the folders to different dates. It always resulted in the same error message. The folder ~/.electrum/wallets is definitely user-writable, even after the restoring process terminated.

One peculiar thing I observed once is that a folder called 2.Filled Wallet was created in in ~/.electrum/wallets. It had the same path as the text file of the wallet I didn't care about which also could not be restored should have.

Because I'm not at home where my raspi is and am on a quite slow internet connection, after trying restoring the file as it was on a few different dates with the same (non-)result each time, I changed the backup path of Deja Dup on my raspi to the backup location of the Deja Dup installation on my laptop (so the raspi was able to access the files locally whereas my laptop has to access them over a slow internet connection) and tried to restore the folder .electrum there. The path of my home directory is the same, both on my laptop and on my raspi. I did, however, restore ~./electrum via the Restore Missing Files... option after right-clicking blank space in my home directory on my raspi via VNC. To specifically point out the difference: On my laptop, I deleted the contents of the folder ~/.electrum but left the folder itself on the disk. I then right-clicked it and chose Revert to Previous Version....

The restoring process terminated with the message that restoring was successful. The files ~./electrum/wallets/default_wallet and ~./electrum/wallets/2.Filled Wallet, however, don't exist in the restored folder. Again, the other 2 wallets do.

How do I restore that file?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.