On Kubuntu 17.04 Zesty i keep getting error 21 (net::ERR_NETWORK_CHANGED). After refreshing pages are loaded well. My downloads are also interrupted because of this error. On Firefox everything is just OK.

What can be reason of this error? I don't think it is caused by WiFi driver, because on other web-browesers i get no errors.

sudo apt list google-chrome-stable 
google-chrome-stable/stable,now 56.0.2924.87-1 amd64 [installed]

lspci | grep -i network
02:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)

sudo modprobe ath9k && dmesg | grep ath
[   20.522563] ath: phy0: WB335 1-ANT card detected
[   20.522564] ath: phy0: Set BT/WLAN RX diversity capability
[   20.532780] ath: phy0: Enable LNA combining
[   20.534814] ath: phy0: ASPM enabled: 0x43
[   20.534817] ath: EEPROM regdomain: 0x6a
[   20.534818] ath: EEPROM indicates we should expect a direct regpair map
[   20.534819] ath: Country alpha2 being used: 00
[   20.534820] ath: Regpair used: 0x6a
[   20.731920] usbcore: registered new interface driver ath3k
[   20.895278] ath9k 0000:02:00.0 wlo1: renamed from wlan0
[   22.460435] audit: type=1400 audit(1487757197.106:9): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/mission-control-5" pid=758 comm="apparmor_parser"
[   22.460438] audit: type=1400 audit(1487757197.106:10): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/telepathy-*" pid=758 comm="apparmor_parser"
[   22.460440] audit: type=1400 audit(1487757197.106:11): apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/telepathy/telepathy-*//pxgsettings" pid=758 comm="apparmor_parser"
[   87.919856] ath: EEPROM regdomain: 0x8268
[   87.919857] ath: EEPROM indicates we should expect a country code
[   87.919858] ath: doing EEPROM country->regdmn map search
[   87.919859] ath: country maps to regdmn code: 0x37
[   87.919860] ath: Country alpha2 being used: PL
[   87.919860] ath: Regpair used: 0x37
[   87.919861] ath: regdomain 0x8268 dynamically updated by country IE
[ 1269.886049] ath: phy0: ASPM enabled: 0x43
[ 1274.311544] ath: EEPROM regdomain: 0x8268
[ 1274.311546] ath: EEPROM indicates we should expect a country code
[ 1274.311547] ath: doing EEPROM country->regdmn map search
[ 1274.311547] ath: country maps to regdmn code: 0x37
[ 1274.311548] ath: Country alpha2 being used: PL
[ 1274.311549] ath: Regpair used: 0x37
[ 1274.311550] ath: regdomain 0x8268 dynamically updated by country I


  • 1
    after upgrading ubuntu to zesty (17.04) i'm seeing the same issue
    – GregL83
    Apr 15, 2017 at 16:32
  • 1
    disabling ipv6 "fixed" the issue but is not long-term solution
    – GregL83
    Apr 15, 2017 at 18:23
  • Same here with Ubuntu 16.10, and it happens regardless of the IP version (v4 or v6) in the network I'm connected to. It seems to be more common with some sites than others. It also happens with an Ethernet connection. Doesn't happen with Firefox on the same computer. This is extremely irritating -- Hopefully we'll find a solution soon!
    – Gus
    Apr 27, 2017 at 10:46

2 Answers 2


Are you using Docker? Do you have Docker networks? Try removing them (except for bridge, host and none). That fixed it for me.

I'm using Kubuntu 16.10 on a Dell Inspiron 13 (5000 series, Intel Corporation Wireless 3165 (rev 79)). This issue used to happen with both IPv4 and IPv6 networks, and both wired and wireless.

You can remove all unused Docker networks with the command:

docker network prune
  • I just tried it and I think it is working, you saved me :)
    – MickaelFM
    Dec 9, 2017 at 10:17
  • Same here, I had some old useless networks lying there, and removing them seems to fix the issue. Thanks !
    – Toilal
    Oct 26, 2018 at 5:51
  • It is working now, docker network seems to be the problem :) Feb 1, 2019 at 12:51
  • that did the trick for me. It kept interrupting my mercure hub connection and I couldn't figure out why. Thanks ! Dec 19, 2019 at 12:15

You can try disabling IPv6 using the following command.

sysctl -w net.ipv6.conf.all.disable_ipv6 = 1
sysctl -w net.ipv6.conf.default.disable_ipv6 = 1

If that works, make the change permanent by adding the following lines to /etc/sysctl.conf

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .