21

It's impossible to write this way, text gets deleted, windows change, random tabs open. I've tried every solution I came across but none actually solve it (some don't even work)

I've tried installing touchpad indicator, I've tried adding a syndaemon option from startup application, I tried the same but from the terminal, nothing works.

I Just want to disable the touchpad completely while typing, no scrolling, no moving the cursor, nothing.

  • 1
    It is very easy. Run xinput disable <ID>. The ID you can find by xinput command. But I suggest installing libinput, it should solve the issues. – Pilot6 Feb 22 '17 at 11:33
  • 2
    @pilot6 Sorry, I meant to say I Want to disable it only while typing, not all the time. – MichaelX Feb 22 '17 at 11:53
  • What is the Ubuntu version? – Pilot6 Feb 22 '17 at 11:53
  • @Pilot6 16.04.1 – MichaelX Feb 22 '17 at 11:56
22

I suggest installing libinput it has much better "disable while typing" and "palm detection" algorithms.

Run

sudo apt install xserver-xorg-input-libinput

and restart the GUI session, or reboot.

If you need "tap to click", you can add

Option "Tapping" "true"

to the touchpad section of /usr/share/X11/xorg.conf.d/90-libinput.conf.

All options can be found on the manual page.

If you are using Ubuntu 16.04 with the -hwe-16.94 stack, you will need to install xserver-xorg-input-libinput-hwe-16.04 package instead of xserver-xorg-input-libinput.

You can check which HWE stack is installed by checking if xserver-xorg or xserver-xorg-hwe-16.04 package is installed.

  • +1 for best answer after OP changed question. – WinEunuuchs2Unix Feb 22 '17 at 12:47
  • I suggested the same in a comment even before OP clarified the question. – Pilot6 Feb 22 '17 at 12:50
  • I had read your comment when it was first activity after thread was startled. Sorry I forgot to raise the comment then I'm bad with that. Rectified :) – WinEunuuchs2Unix Feb 22 '17 at 13:15
  • 2
    The scrolling should be normal, not "natural". It is possible to reverse it, but it seems that you used natural before. – Pilot6 Feb 22 '17 at 13:24
  • 1
    The option is "NaturalScrolling". Try "true" and "false" to get what you want. "False" is the default. – Pilot6 Feb 22 '17 at 13:25
10

Open System Settings -> Mouse & Touchpad : in the Touchpad section switch from ON to OFF

enter image description here

Additional information for other users reading this post : The answer was written before the content of the question was changed, originally the question was : "An actual solution to disable touchpad? I just want to disable the touchpad completely, no scrolling, no moving the cursor, nothing." - so the answer from @Pilot6 is the much better solution for what the current version of the question is asking about !

  • 1
    Sorry. My mistake. I messed up the title. I want to disable the touchpad while typing, not disable it all the time. – MichaelX Feb 22 '17 at 11:50
3

You can also do it with Synaptics.

synclient PalmDetect=1

That will not be permanent, but you can do this by creating or editing the following file and adding Option "PalmDetect" "1"

# /etc/X11/xorg.conf.d/70-synaptics.conf
Section "InputClass"
  Identifier "touchpad"
  Driver "Synaptics"
    Option "PalmDetect" "1"
EndSection

https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Disable_touchpad_while_typing

2

In my eyes, palmdetect is not exactly "disable while typing", because this feature doesn't really consider what's happening on the keyboard. In my case, I don't permanently touch the pad while typing, so the detection didn't work properly. On the same link that HarlemSquirrel already posted, there's also a second solution which does exaclty what is requested (in the modified OP):

Using syndaemon syndaemon monitors keyboard activity and disables the touchpad while typing. It has several options to control when the disabling occurs. View them with $ syndaemon -h For example, to disable tapping and scrolling for 0.5 seconds after each keypress (ignoring modifier keys like Ctrl), use

syndaemon -i 0.5 -t -K -R

Once you have determined the options you like, you should use your login manager or xinitrc to have it run automatically when X starts. The -d option will make it start in the background as a daemon.

  • I confirmed that this is working on Ubuntu 19.04 LTS running the standard Gnome desktop. This is with synclient -l | grep PalmDetect returning PalmDetect = 1 (which was enabled by default, not by my own changes). This implies, to me, that just having synclient's PalmDetect set to 1 is not the solution, your answer is. – bgoodr Jun 15 at 18:54
0

This is very similar to How do I disable a touchpad using the command line? which recommends the synclient program.

If you have a Synaptics touchpad, then you can bind hotkeys to turn the pad off and on with

  • synclient TouchpadOff=1
  • synclient TouchpadOff=0
  • Does this answer the question regarding automatic "disable while typing" feature? – Pilot6 Feb 23 '17 at 16:47
  • It doesn't do so automatically, but I've found it useful and doesn't require the addition of another package. Either way is good. Yours is automatic; mine while manual is also valid for the OP's question. – Rache Feb 23 '17 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.