4

When I open dark dark applications my screen changes brightness automatically.

How can I disable this feature?

I have already un-checked the following options for battery and AC power:

  • Reduce backlight brightness.
  • Dim display when idle

My brightness is set to 100%

However, I am still getting the same behaviour.

My Laptop is: Dell Inspiron 14 5447

My OS is: Ubuntu MATE 16.04

My graphic card is hybrid (Intel+ATI)

From Additional Drivers Unknown: Unknown is installed and it is (a proprietary) one

Any help is appreciated.

lsusb command result:

Bus 001 Device 005: ID 0bda:5754 Realtek Semiconductor Corp. 
Bus 001 Device 004: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 003: ID 8087:07dc Intel Corp. 
Bus 001 Device 006: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

lspci -vvnn | grep ATI command result:

03:00.0 Display controller [0380]: Advanced Micro Devices, Inc. [AMD/ATI] Topaz XT [Radeon R7 M260/M265] [1002:6900]
4
+125

Temporary change for current session

To enable or disable the Ambient Light Sensor (ALS) using the keyboard:

  • Hold the Fn key and press the 🡸 key to enable or disable ALS.
  • Hold the Fn key and press either the 🡹 key or the 🡻 key to disable ALS and set the LCD brightness manually. Pressing the 🡹 key brightens the display, and pressing the 🡻 key dims the display.

From (What is the Ambient Light Sensor feature on a portable computer - Dell)

Permanent change across boots

You can turn off Ambient Light Sensor (ALS) within the BIOS. However, older posts in some forums suggest the BIOS (Press F2 on boot) didn't provide options for disabling the ALS. Answers on those forums say a BIOS update from Dell was necessary.

If you don't find an option in BIOS for turning off ALS permanently, check Dell support site for BIOS update. Entering your system tag number is the easiest method else you'll have to manually locate the relevant drivers.

  • Those keybindings are only correct for a very specific subset of computer. My own Dell has scrolling keys (Home/End, PageUp/PageDown) on the arrow keys, not brightness. – Kaz Wolfe Feb 28 '17 at 6:48
  • Not solving my problem – malhobayyeb Mar 4 '17 at 13:16
3

here few links it might help

https://www.maketecheasier.com/configure-screen-brightness-in-ubuntu/

another question gets a reply

On Dell Latitude laptops, the auto-brightness can be disabled in the BIOS. Reboot the computer and hold F2 before it starts. Look around in the menus for ALS or ambient light sensor. There you will be able to disable it. answered Jul 10 '16 at 1:08 user232591

Disable automatic brightness according to content in Ubuntu 14.04

  • Not solving my problem – malhobayyeb Mar 4 '17 at 13:16
0

This sounds like AMD ATI Varibrite and it's super annoying. If you have fglrx-amdcccle installed, you can launch it ( I think as root ) and disable it. You might be able to find it in the repositories if it's not already installed. Try:

sudo amdcccle or sudo fglrx-amdcccle or something like that.

If not, you could try following this article https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=652334 and see if you can turn it off that way. I had this issue 2 years ago so I can't remember the exact details.

  • Not solving my problem. – malhobayyeb Feb 26 '17 at 10:02
  • This can't be a solution as the bug you linked to relates to the fglrx driver which isn't supported by the version (16.04) of Ubuntu the OP identified. – Elder Geek Mar 4 '17 at 16:49
0

I don't own a Latitude model instead an XPS, which suffers the same issue.

On my model, there is a firmware that directly handle with the Dynamic Backlight Control and there isn't a software which directly control it.

https://github.com/advancingu/XPS13Linux/issues/2

The only way to fix it, is via a firmware upgrade but this must be provided by Dell.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.