2

I can not access my 1 TB HDD in any system ubuntu or windows after I recently tried to backup my ubuntu system on the external HDD using inbuilt applications (Backups, Deja Dup) . Backup was taking place smoothly in the middle of that it stopped working and I force quit all operations and restarted my laptop but now the hard disk can not be accessed and making my laptop hang whenever trying to access it.

As the data is important to me I tried using Photorec running it on a live usb stick. I went through this tutorial step by step, want to mention, each step was taking more than half an hour sometimes a whole hour but as they said, to be patient I was following each step carefully, now at the recovery step most of the sectors are showing reading error and estimated time is 133895h54m25 and keeps on increasing. Right now it is

   > Photorec 7.0 Data Recovery Utility, April 2015Christophe GRENIER <grenier@cgsecurity.org>http://www.cgsecurity.orgDisk /dev/sdd - 1000 GB / 931 GiB (RO) - Seagate BUP Slim BK   Partition            Start         End        Size in sectorsP unknown          0     0      1    953869      45    15   1953525167   
Pass 0 - Reading sector     20631/1953525167, 0/10 headers found
Elapsed time 1h27m30s -Estimated time to completion 132332h45m05
Error reading sector      21528
>

What should I do in this situation? thanks.

marked as duplicate by Andrea Lazzarotto, Zanna, MadMike, David Foerster, Elder Geek Mar 20 '17 at 12:40

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    "most of the sectors are showing reading error" - That probably means it's not going to work. – Android Dev Feb 21 '17 at 22:20
  • I would wait a couple of hours and if the speed doesn't pick up turn it off and use 'testdisk' instead. But in such a gut wretching situation you have to make that call yourself. – WinEunuuchs2Unix Feb 21 '17 at 23:20
  • @WinEunuuchs2Unix I tried testdix before hand, it showed no partition found and quick search doesn't help. Should I do it on my installed ubuntu on my laptop instead of live usb and see if it is faster there? or do I need professional assistance here ? – Onix Feb 22 '17 at 1:48
  • 1
    I used only Analyse feature with >testdisk> and result was no partition found. I could not perform dd as my hard disk is 1 TB and I don't have another hard disk. I couldn't understand other options like Advance and MBR code – Onix Feb 22 '17 at 3:23
  • 1
    I had the same issue, estimated time to completion was 5.3 years, but in fact the whole 1 TB disk (classic WD My Passport with NTFS) process ended after 3 hours. I file this bug. – Pablo Bianchi May 24 '17 at 23:27