2

My computer is not a laptop and does not have a built-in screen. But Ubuntu thinks it does, and chooses it as primary display, meaning everything is off-screen(!).

How can I inform Ubuntu that there is nothing there?

$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
eDP-1 connected (normal left inverted right x axis y axis)
   1920x1080     60.00 +  59.93  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   960x600       60.00  
   960x540       59.99  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   800x512       60.17  
   700x525       59.98  
   640x512       60.02  
   720x450       59.89  
   640x480       60.00    59.94  
   680x384       59.80    59.96  
   576x432       60.06  
   512x384       60.00  
   400x300       60.32    56.34  
   320x240       60.05  
HDMI-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 527mm x 296mm
   1920x1080     60.00*+  50.00    59.94  
...
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)

There is nothing connected to eDP-1!

I am using Ubuntu Gnome 16.04. Currently I 'fix' the problem by:

  1. logging in (without being able to see what I'm doing)
  2. move the mouse over to the screen that does exist.
  3. Press the Windows[sic] key to access Activities
  4. Type term and Enter which starts Terminal near my mouse
  5. From there run gnome-control-centre, and turn off the "built-in display".
3

Here's how I got around this.

From the xrandr output get the name of the troublesome ghost screen. In my case (see question) it is eDP-1, but others might have LVDS-1 or something.

Append this kernel param (credit to this superuser answer):

video=eDP-1:d

The :d means disable this, even if something is plugged in.

And now it works. For completeness' sake, to append a kernel param once you can do a reboot, wait till you see the blank grey screen and hit Escape which should hopefully then show you a GRUB menu. Press e to edit the ubuntu entry, move the cursor to the end of the line that starts with linux ... and add the above (there should be a space before it). I suggest you try parameters this way first - otherwise you could end up with an unbootable system if you get it wrong.

To make this stick, once you've found something that works, edit /etc/default/grub and look for the GRUB_CMDLINE_LINUX_DEFAULT line and add your parameter within the quotes like so:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=eDP-1:d"

Then run sudo update-grub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.