1

since I don't know when Synaptic does not work. When I launch Synaptic from the dash, the icon appears for some seconds, that's all. On the other hand, Synaptic works, when I launch it from the terminal. How can I fix this?

$ synaptic-pkexec 
==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic ===
Authentication is required to run the Synaptic Package Manager
Authenticating as: Christian Hartmann,,, (christian) Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie 
==== AUTHENTICATION FAILED === 
Error executing command as another user: Not authorized 
This incident has been reported.
  • Are you trying to run from a terminal window or from the Unity dash? Try from the terminal using "sudo synaptic". If this does not work, post the error you get. – Juan Antonio Feb 21 '17 at 16:35
  • as I said: it does not work when I launch it from the Unity dash. From the terminal it works fine. Only that I find the dash more comfortable and that I hate it, if something does not work as it should – Christian Hartmann Feb 21 '17 at 22:26
  • Try reinstalling it. – Juan Antonio Feb 22 '17 at 19:31
  • tried to reinstall it several times. Nothing changes! – Christian Hartmann Mar 13 '17 at 22:07
  • I tried synaptic-pkexec: ==== AUTHENTICATING FOR com.ubuntu.pkexec.synaptic === Authentication is required to run the Synaptic Package Manager Authenticating as: Christian Hartmann,,, (christian) Password: polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie ==== AUTHENTICATION FAILED === Error executing command as another user: Not authorized This incident has been reported. – Christian Hartmann Mar 13 '17 at 22:13
2

This happened for me just now on Ubuntu Mate, and after a bit of searching I found a solution for another distro but which I could adapt to my distro as well.

The "synaptic-pkexec" program is just a script that starts synaptic using "pkexec". "pkexec" launches a dialog to ask for your password, but instead of just reading /etc/sudoers (like sudo) it uses PolicyKit which uses an "authentication agent" that needs to be running in the background.

Apparently, the authentication agent was not running because I had somehow managed to uncheck the PolicyKit Authentication Agent from my list of Startup Applications. (not that a agent/daemon belongs among applications ...) I checked it in the Startup Applications Preferences, logged out and back in again and now "synaptic-pkexec" and other admin programs work.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.