I have a Dell XPS 13 running Ubuntu 16.04. Over the last weekend, I've noticed that this laptop will shut down instead of suspending - whether it's a result of the lid closing or manually hitting suspend.

I have tried editing my /etc/systemd/login.conf (for HandleLidSwitch) as well as /etc/default/acpi-support (for SAVE_VIDEO_PCI_STATE), but neither approach has worked. I read Ubuntu shuts down on suspend? but there seems to be no answer.

What can I do here?

  • Do you have a swap partition ? – Ramon Suarez Feb 21 '17 at 8:57
  • I have this problem too, on a Sony VAIO laptop that just started doing this with an installation of Ubuntu 16.04. It seems like it sleeps at first, and then crashes during the time I'm gone. However, hibernate works for me, so I just use that. It's almost as fast. – Nonny Moose Feb 21 '17 at 13:09
  • 1
    Same. Suspend on my XPS 13 worked perfectly until about February 20th-25th. Now about 95% of attempts to suspend, whether through the menu or by closing the lid, result in a shutdown instead. It rarely works, and I haven't been able to establish a pattern in those cases in which it works. – Erin Ishimoticha Mar 10 '17 at 22:25

I have the same issue with an XPS 13 9350 and Ubuntu 16.04. The issue was resolved for a little while when I followed this solution: Sony Vaio FW350 reboots instead of waking up after sleep/suspend

Now it's randomly back to shutting down instead of suspend.

You can click the suspend button in the top right menu (under the gear icon) while waiting for a solution, although even this works inconsistently on my XPS 13.

  • can anyone confirm if the VAIO fix works for Dell XPS ? – Asaf Jun 27 '17 at 9:17

I have Ubuntu 17.10 & Win10 dual boot and I recently had the same issue.

What worked for me is forcing Win10 to a full shut down, then the Ubuntu suspend process was back to normal.


Add radeon.modeset=1 radeon.drm=1 radeon.runpm=0 to GRUB_CMDLINE_LINUX_DEFAULT of /etc/default/grub.

Reference: https://lists.ubuntu.com/archives/ubuntu-users/2016-July/285902.html

It worked for my HP Pavilion g6 AMD E2-3000M APU with Radeon(tm) HD Graphics × 2

Ubuntu 16.04 LTS

  • It turned out that GRUB_CMDLINE_LINUX_DEFAULT="quiet radeon.modeset=1" was sufficient. Removing "splash" from it is important. If "splash" remains, vt.handoff=7 is appended to kernel option, then after first boot screen goes into black. See /etc/grub.d/10_linux for this vt.handoff addition. – yoshinobu Mar 9 '18 at 12:04

I had the same issue with my Dell latitude e7270 and Ubuntu 16.04 LTS. My problem was solved when updating my kernel following the instructions here

This probably means it is an Ubuntu issue and I guess updating your kernel might do the job.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.