0

I recently installed Kubuntu 16.10 and decided to use Full Disk Encryption during installation (LVM with Encryption was the option I chose I believe).

Now the thing is that the system asks me for the encryption password when I boot it up and the user password to login. I'd rather just have the system login automatically once the encryption password has been entered since I'm the only user on the system (i.e. 1 password is sufficient for me).

So I looked through the system settings and found "Account Details" which has "User Manager" as an option (so System Settings -> Account Details -> User Manager). Under here, my user has the the check box "Automatic Login". I toggle that, click Apply. Restart the computer to test and I still get two password prompts. If I go back into the settings after the reboot, I see the Automatic Login is unchecked. How do I get Kubuntu 16.10 to let me login automatically?

2

It appears to be a bug as reported here. The fix they offered is as follows:

  1. Create a file /etc/sddm.conf

  2. Add the following:

    [Autologin]
    User=YourLogonID
    Session=plasma.desktop
    
    • Please note YourLogonID == YourLogonName
  3. Then try again.

Source:

https://bugs.launchpad.net/ubuntu/+source/linux-armadaxp/+bug/1565601

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.