I recently ran updates using the software updater. After restating my computer, whenever I plug my WiFi adapter into a USB port the entire screen freezes. (It does not freeze when I plug it in with networking disabled.) Is there any way that I can fix this?

  • I'm sorry, but without further information regarding your hardware it's impossible to begin to write a useful answer to this question. Please edit this post after reviewing askubuntu.com/questions/425155/… . You might also find this useful.
    – Elder Geek
    Feb 21, 2017 at 17:46

3 Answers 3


I experienced this sort of problems after the updates installed a new version of the kernel (so, not any update). This sometimes confuses the handling of interfaces.

If that's actually the case, my solution has been to let the computer to boot from the previous kernel version until a newer working release is distributed.

To this end I edit the boot menu using the program grub-customizer. To install it (and you obviously need an Ethernet connection if the wi-fi receiver is malfunctioning), follow these instructions:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer

The program is a GUI for handling the settings of the boot loader. There, you can visualize the list of kernels still available in your systems from the tab 'List configuration'

Grub Customizer List configuration

With the other tab 'General settings' I can change the kernel loaded at boot time. In the snapshot below I am set to select 4.4.0-62 generic from the 'default entry: predefined` area. That version is the last but one in the list shown above.

Grub Customizer General settings

Then you save your selection. After the next reboot, the system will start from the earlier kernel as per your selection. If your problem has disappeared, you have framed the culprit. If not, this avenue has not been successful, alas, and the problem resides elsewhere --- you can then revert your boot-loading selection.

Incidentally, you can also see which kernel version is currently running from the command line with uname -r.

  • 1
    I had the same issue and this worked booting from 4.4.0-59, i'm wondering if a new kernel update could overwrite this setting or it keeps booting from the kernel chosen until changed manually? Feb 24, 2017 at 17:41
  • @SandroAntonucci -- I can't recall exactly because, when I noticed that a new kernel had been downloaded, I put that to the test with grub-optimizer ahead of a plain reboot. My guess is that your selection will persist if you have selected a particular version as default entry, while it will catch up with the one at the top of the timeline (the newest) if you choose the option '(first entry)' Feb 24, 2017 at 18:54
  • @swordf1zh Pleased to hear that. If you didn't, please consider upvoting questions and answers that have been useful and clear. This increases the visibility of valuable threads. Feb 28, 2017 at 19:39
  • Same problem, with a TP-Link Wifi adapter. I updated, and at next restart, my computer froze up, as soon as I plugged in the TP-link. By choosing to start from kernel 4.4.0-57, instead of 4.4.0-72, I'm having no problems.
    – theodorn
    Apr 22, 2017 at 19:22

I followed these instructions to compile a new driver for the RTL8192C:


So far, its working.

  • Please add contents of those steps... Mar 5, 2017 at 18:25

I installed old kernel 4.4.38-040438-generic and it works too. Here is how to install old kernal via command line.

I pick the kernel at http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.4.38/

If your machine is 64 bits server, choose "Build for amd64 succeed"

Download these 2 files

# wget linux-headers-4.4.38-040438_4.4.38-040438.201612101547_all.deb
# wget linux-image-4.4.38-040438-generic_4.4.38-040438.201612101547_amd64.deb

After the deb packages has been downloaded, install with the command below

# dpkg -i linux-headers-4.4.38-040438_4.4.38-040438.201612101547_all.deb
# dpkg -i linux-image-4.4.38-040438-generic_4.4.38-040438.201612101547_amd64.deb

Reboot the machine, and it should pick the earlier Kernel instead of latest kernel.

Plugged in the USB Wifi Dongle, no more freezing ;)

Read couple of forums, and still no fixed for latest kernel.

  • How do you know this will work for OP with such little info given?
    – M. Becerra
    Mar 15, 2017 at 12:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.