0

I've upgrade my Ubuntu 12.04 to 14.04 using the update manager. After the install finished (it took several hours) the system froze so i had to turn off the notebook with the power button (I've wait a long time before do it). After reboot and selecting Ubuntu (I have Ubuntu installed alongside Windows 7) it displays this message:

No init found. Try passing init=bootarg

I started Ubuntu from a live USB and try to pass the fsck command but the whole Ubuntu partition just isn't there. With fdisk -l it only displays 3 partitions:

/dev/sda1--->System_DRV 1.17 Gb  
/dev/sda2--->The Windows 7 partition 454 Gb  
/dev/sda3--->the Lenovo Recovery partition 9.77 Gb

The disk have 500 Gb so there's some space missing. I'm no expert in Ubuntu so I don't have many ideas on solving this problem.

When the computer starts it shows the 2 OS for selecting and if I try to fresh install Ubuntu it says that I have various OS installed and give me 2 options: Format all the disk and install only Ubuntu or manually manage my partitions (it also shows only those 3) but none of my files are there for access, I just can't manage to find that part or mount it.

I don't care to recover the files, I've made a backup of them before the upgrade, but I need Ubuntu installed, and also that space that it is occupying.

edit: Here is the screenshot of gparted

enter image description here

5
  • Hmm, this is weird. Looks like your Windows partition took over. It is normal that you "miss" some space from the number on the box (so you'll never have 100% of your 500GB). When you run the following command: ``` sudo fdisk /dev/sda ``` is it complaining? Also, do you have more than one disk in your laptop? How did you install Ubuntu? – incredibleholg Feb 20 '17 at 16:44
  • Best to edit your question to include a current-window-only screenshot of gparted (when booted to the Ubuntu Live DVD/USB), and we'll take a look. – heynnema Feb 20 '17 at 17:00
  • With gparted or installator, you should see some 20 GB not used. Do yo? – jaromrax Feb 20 '17 at 17:04
  • @incredibleholg Here's the output. imgur.com/YJlAKjs And no, i only have one disk. I was making an upgrade from 12.04 LTS to 14.04 LTS using the update manager. – Fer Feb 20 '17 at 20:25
  • This is a problem - what does the red exclamation mark says? – jaromrax Feb 21 '17 at 12:55
1

***** This is an advice before the screenprint of gparted was shown, it is not enought to follow 1-3, you would need 1/ detect the problem 2/ to consider the text in italics *****

You dont need to find the partition for a fresh install.

There are few dangers, you could loose all your partitions, so backup first.

My experience is that Ubuntu takes about 15 GB, you need some /tmp space and /home space. Personally, I would a) defragmented Windows7, booted from USB with gparted and tried to make some reasonable space for Ubuntu on behalf of Windows7. Anyway, if you dont feel strong, or you dont care:

1) boot with Ubuntu 16.04 (you evidently use LTS editions)

2) Start with install, manually create 4th partition, that will contain two (at least) logic partitions - a 1) swap partition of a size of your RAM*2 (maybe it is possible to omit swap nowadays?) and ext4 for Ubuntu (/) that fills the last bytes of the disk.

3) Install to a new partition, grub should take care about the rest.

6
  • There was a question on taking care of dual boot....If not, I would recommend deleting win7 completely. #3 - grub takes care about everything. I would worry more in new systems, but here, Ubuntu already worked once. – jaromrax Feb 20 '17 at 17:47
  • My problem is that i don't have a device to make a backup. In case that I make a new partition for a fresh install, what will happen with the rest of the space that gone missing after the upgrade? – Fer Feb 20 '17 at 20:11
  • You said, you dont care about the files, didnt you? Either you find (in the beginning of the installation) that there is a free space for your partition, this means your previous partition simply disappeared. Or you find, there is not enough space to create the new partitions, then, I dont know what happened, but you would need to resize Win7 partition. Every partition change is dangerous, you should make a backup. I was lucky until now, but always I had a data bakup. – jaromrax Feb 21 '17 at 12:53
  • Oh - now I see a new picture with gparted ! What is a text comment to the problem with NTFS? Do you still see windows? – jaromrax Feb 21 '17 at 12:54
  • Sorry for that, i forgot to mount the drive so Gparted cannot read it. After mounted it appears fine. imgur.com/bGOwnQO Windows works and i can access all it's files from Ubuntu. I think i'll try to get a disk for backup the win7 files and make a new partition through the Ubuntu installation. I didn't found any other way. Still I don't understand why the grub shows Ubuntu, and how the whole partition dissappeared from one second to another. Thank you for your help! – Fer Feb 21 '17 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.