2

I have perl V5.22.1 installed by default in ubuntu 16.04 , I would like to know how to downgrade perl to version 5.20.3 , I have used perlbrew but it doesn't seem to work properly , are there any alternatives to perlbrew to downgrade perl , please let me know .

3
  • I'm using perlbrew without problems in ubuntu 16.04. Thus I recommend you figure out why perlbrew doesn't work properly because the chance is high that you are running in exactly the same problems with another way of installing an alternative version of perl. Feb 20 '17 at 15:34
  • @SteffenUllrich now i can use perlbrew, i have another problem, i would like to set Perl 5.20.3 as default perl instead of perl 5.22.3 . Could you please let me know how i can do that without perl brew, i know we can switch from one version of perl to another .
    – DevanDev
    Feb 25 '17 at 12:20
  • 1
    Please don't ask a different question in the comment of another question. Apart from that just read the documentation of perlbrew (man perlbrew) which includes the answer. Feb 25 '17 at 12:44
4

List what you can install and use, with

perlbrew available

Install what you want from the list, with

perlbrew install perl-5.20.3

See what you can use in this system, with

perlbrew list

Use what you want, in the current shell with

 perlbrew use perl-5.20.2 # for this terminal only
 perlbrew switch perl-5.20.2 # every time you log-in

Revert to the older version with

perlbrew off        # for this terminal only
perlbrew switch-off # every time you log-in

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.