I have 16.04 (upgraded from 14.04) that worked well.

Once I activated Nvidia proprietary controller, I get locked in a login loop.

I tried ctrl + alt + F1 to F6, none of them worked (got a black screen).

I made a bootable USB from where I have acces to original disk, from there I tried delting /home/<user>/.Xauthoritybut it didn't work.

What I would like is just to revert the activation of Nvidia proprietary controller, getting it back to X.Org X Server.

Before been considered a duplicated, I wen't carefully through Graphics issues after/while installing Ubuntu 16.04/16.10 with NVIDIA graphics but nothing there could be applied to my issue.

  • Have you disabled secure boot in the BIOS? Feb 20, 2017 at 12:11
  • I didn't until you suggested, but nothing changed.
    – Marc
    Feb 20, 2017 at 12:54
  • Now that you've disabled it, use recovery mode to purge and reinstall the Nvidia drivers. Feb 20, 2017 at 13:42

1 Answer 1


Finally I managed to boot my system normally (but without nvidia drivers). I think all the credit should be given to here, but it was hard to me to figure out how to do some things. I'll try to give some important details. The steps I took are:

Enter recovery mode or 'BOOT into GRUB'

I only have Ubuntu on my install, so no GRUB menu appears on booting. Instead had to press only once 'esc' key, right after the bios logo dissapeared (prior to 16.04 the key has to be left 'shift')

At the begining, as AndroidDev suggested I dissabled secure boot in the BIOS, but later I enabled it again and could enter in recovery mode without any problem, so I would say it has nothing to do.

Once I entered in the GRUB menu, was easy to boot in recovery mode, just have to look around until you see the option that explicits 'recovery mode' (I had several, I suposes each of them references one version of the kernel, so I booted with the highest (latest).

Uninstall nvidia drivers

I then choose the root console and issued

sudo apt-get purge nvidia-*

but finally it didn't do anything, because filesystem was readonly. So first I had to run fsck, from the previous menu (not from console). After that, I rerun the purge command.

Deleting .Xauthority

Somewhere in the process deleted /home//.Xauthority with sudo rm /home/<user>/.Xauthority

I'm sure only this didn't do the trick, but is something more to try.

Installing the proprietary drivers

I tried once again to install the nvidia drivers, but this time from the terminal... as soon as drivers were installed and restarted, I got stucked in the same login loop ... so had to purge the drivers again.

  • I'm not sure if this should be posted as an answer, since basically it is a reformulation of another answer. Please feel free to guide me with that.
    – Marc
    Feb 21, 2017 at 0:00
  • Now I know I can't use Ctrl+Alt+F1 to open a terminal, so have to check that, and I can't install Nvidia drivers, wich I think may be causing Android Emulator nor genymotion not working at all.
    – Marc
    Feb 21, 2017 at 0:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .