3

I know, by now, that this particular question has been answered again and again and again and again. I have been trying all of the suggested cures to this menace, but nothing seems to work.


First of all, my system comprises of: an AMD Phenom X4, GeForce GTX 960 and I have installed every possible driver (367, 370, 375, 378) and nothing solves my problem which is this:

iraklis@panisxyros:~$ steam
Running Steam on ubuntu 16.10 64-bit
STEAM_RUNTIME is enabled automatically
[2017-02-20 13:12:44] Startup - updater built Jan 19 2017 01:22:13
SteamUpdateUI: An X Error occurred
X Error of failed request:  BadValue (integer parameter out of range for operation)

Trying to add a little more verbosity i did a:

iraklis@panisxyros:~$ LIBGL_DEBUG=verbose steam

but I got the exact same output message, although this happens only with the 367 drivers loaded. When all of the other drives were loaded I got some extra info, such as:

libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
libGL error: failed to load driver: swrast

The solution is always a thing with an old version of libstdc++, but this problem is solved, since the steam package installed from the repo, takes care of this internally.


Anyway, the most baffling things are:

  1. When I tried using my old GPU (an ancient GT 210) Steam worked just fine (with 340 drivers installed)
  2. When I use the nouveau driver, Steam does work, but the performance is so bad that it renders my computer unusable.

So, any other suggestions would be so very welcome. Thanks in advance.

  • Hi and welcome to AskUbuntu! Thank you for taking the time to do your research, do a lot of troubleshooting on your own, and then write a high-quality question detailing your problem. If only all new users wrote questions like this.... :) – You'reAGitForNotUsingGit Feb 20 '17 at 11:49
1

After a week of meddling around I finally found a solution, which was easier than I could have expected. For anyone that might seem useful, it was just a problem with misconfiguration in /etc/ld.so.conf.d. Although I have been there before and started tweaking I haven't found any solution, until I stumbled upon this file bug and more specifically here. So, the problem is that for some twisted reason my system was pointing into the mesa library, rather than the nvidia. So all it was needed was a:

sudo update-alternatives --config i386-linux-gnu_gl_conf

and checking the appropriate library, then

sudo ldconfig

and BOOM steam started like a charm!

|improve this answer|||||
  • Congrats for your fix! – Leder Feb 26 '17 at 11:26
0

This solution for libstdc++ is not solved, as far as I know, so please see accepted answer here: steam_libstdc++

otherwise try this solution with new environment variable STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0:

cd $HOME/.steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu
mv libstdc++.so.6 libstdc++.so.6.bak
cd $HOME/.steam/ubuntu12_32/steam-runtime/amd64/usr/lib/x86_64-linux-gnu
mv libstdc++.so.6 libstdc++.so.6.bak

dconf write /org/compiz/profiles/unity/plugins/unityshell/show-launcher '""'
STEAM_RUNTIME_PREFER_HOST_LIBRARIES=0 /usr/games/steam
dconf write /org/compiz/profiles/unity/plugins/unityshell/show-launcher '"Super"'
|improve this answer|||||
  • Plz update your question with code blocks, do not use comments for additional information ☺️ – Leder Feb 20 '17 at 12:14
  • Sorry for this, I'm unfamiliar with mini-Markdown. Although I was trying to answer to your comment about how the steam package does solve the conflicting library issue. It is actually pretty straightforward, since it simply removes libstdc++ every time steam starts. – iraklis Feb 20 '17 at 12:23
  • I tried all possible combinations of steam lib and host lib, this worked for me: 1. Try above script to get a working steam update and tray icon menu 2. Switch to big picture 3. Do normal steam startup into big picture 4. If experiencing any update problems repeat procedure from 1. Without big picture – Leder Feb 20 '17 at 13:26
  • Additionally I switched to clientbeta when I had a running big picture configuration... – Leder Feb 20 '17 at 13:30
  • Yeah, the problem is that as I describe in the title I use KDE, not unity, so I don't actually know how to implement that into my system, although as I can understand, it has something to do with the icon of the application, so it's not that important right now, I can live with starting steam from terminal. Also, steam is installed and is running fine, but only when I use the nouveau drivers (with great deterioration in performance). I did a fresh install of steam yesterday, let it do any upgrades it needed and then switched to nvidia, in which I can't seem to get it running. – iraklis Feb 20 '17 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.