I know there are many other posts and forums concerning this, but I tried most of their suggestions and can't get it to work.

I got a new laptop and installed a fresh Ubuntu 16.04. I don't like the trackpad because I like mice better and I don't like it when the trackpad interferes when I'm typing. I've seen posts that ask how to turn it off only when typing, but I really just want it off permanently.

The two most common answers I've seen are:
1.) Toggle the on/off switch under "Mouse & Touchpad" in Settings.
2.) Type xinput list, then xinput set-prop DEVICEID "Device Enabled" 0

Neither of these worked, but they did both temporarily disable the mouse, but if I touched it a certain way it would start working again. It's hard to describe, but I have a feeling that I might have multiple touchpad drivers or something.

This is the output from xinput list, I tried disabling 13 but I didn't want to mess around with it too much and break anything.

    ⎡ Virtual core pointer                      id=2    [master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
    ⎜   ↳ Logitech M545/M546                        id=9    [slave  pointer  (2)]
    ⎜   ↳ ALP0011:00 044E:120C                      id=11   [slave  pointer  (2)]
    ⎜   ↳ AlpsPS/2 ALPS GlidePoint                  id=13   [slave  pointer  (2)]
    ⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
        ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
        ↳ Power Button                              id=6    [slave  keyboard (3)]
        ↳ Video Bus                                 id=7    [slave  keyboard (3)]
        ↳ Sleep Button                              id=8    [slave  keyboard (3)]
        ↳ HP HD Camera                              id=10   [slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
        ↳ HP Wireless hotkeys                       id=14   [slave  keyboard (3)]
        ↳ HP WMI hotkeys                            id=15   [slave  keyboard (3)]

I don't want to physically disable/unplug the touchpad because I don't want to go ripping apart my new laptop.

Thanks

  • From another answer, does gsettings set org.gnome.desktop.peripherals.touchpad send-events disabled in a terminal work? – Chai T. Rex Feb 20 '17 at 0:28
  • That did work, but after I rebooted it stopped working entirely, even after rerunning the command. – Nate Schultz Feb 20 '17 at 1:20
  • Ahh, sorry that didn't work. – Chai T. Rex Feb 20 '17 at 1:21

The simple way is to use:

xinput disable 13

Try this first at the terminal every time you boot. If you are happy then put it in Startup Applications.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.