1

I am a noob in linux, I hope you can help me I am using a computer I built a couple of years ago with dual boot (Windows 7/ Ubuntu 14.04) my internet connection using an ethernet cable works perfectly in windows 7 but is not working in ubuntu, instead I am using a TL-WN7200ND usb adaptor that works very slow.

Here I post some info:

Board: Gigabyte 970A-UD3P

When Ubuntu is starting it shows the message: "waiting for network configuration"

Outputs for some commands:

    ~$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr fc:aa:14:e5:93:c2  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:44 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:420 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5179 (5.1 KB)  TX bytes:2955 (2.9 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1131 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1131 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:133304 (133.3 KB)  TX bytes:133304 (133.3 KB)

wlan0     Link encap:Ethernet  HWaddr 90:f6:52:0c:4d:d2  
          inet addr:192.168.15.206  Bcast:192.168.15.255  Mask:255.255.255.0
          inet6 addr: fe80::92f6:52ff:fe0c:4dd2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:94866 errors:0 dropped:0 overruns:0 frame:0
          TX packets:66743 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:91597403 (91.5 MB)  TX bytes:11078624 (11.0 MB)


    ~$ sudo lshw -class network
  *-network DISABLED      
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 0c
       serial: fc:aa:14:e5:93:c2
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8168g-2_0.0.1 02/06/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:73 ioport:d000(size=256) memory:fe100000-fe100fff memory:d2100000-d2103fff
  *-network
       description: Wireless interface
       physical id: 1
       bus info: usb@8:1.4
       logical name: wlan0
       serial: 90:f6:52:0c:4d:d2
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt2800usb driverversion=3.16.0-44-generic firmware=0.29 ip=192.168.15.206 link=yes multicast=yes wireless=IEEE 802.11bgn



~$ iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"AXTEL-5879"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: E0:1D:3B:46:7B:C8   
          Bit Rate=58.5 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=31/70  Signal level=-79 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:3  Invalid misc:53   Missed beacon:0

lo        no wireless extensions.

    ~$sudo nano /etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp


~$ cat /var/lib/NetworkManager/NetworkManager.state
[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true


~$ cat /etc/NetworkManager/NetworkManager.conf
 [main]
 plugins=ifupdown,keyfile,ofono
 dns=dnsmasq

[ifupdown]
managed=false

I hope you can help me, I really want to start using Ubuntu. Thank you!

1

Windows can disable the Ethernet adapter when it shuts down as answered in this Q&A: (Ubuntu (dual boot Windows) Ethernet Not Connecting/Detecting). If this is the case then (under Windows XP) follow these steps:

Right click my computer and choose "Properties"
--> "Hardware" tab   --> Device Manager
 --> Network Adapters
  --> "double click" Realtek ...
   --> Advanced tab
    --> Wake-On-Lan After Shutdown
     --> Enable

Sorry I don't have Windows 7 handy to list the detailed steps for it but you should be able to figure them out with the steps listed above and a little google if necessary.

0

It looks like your wireless connection is currently in use. In general, you must disable one network to enable another.

Have you attempted the connection without the wifi device? The results you posted seem to indicate you're currently connected to a network with your wireless, while your ethernet connection is disabled.

  • Yeah, wireless is working but when I try to connect using the cable it doesn't work (With wi-fi disabled and the usb adapter disconnected) – Diego Shierra Costa Feb 19 '17 at 23:35
  • Have you tried the solution here? – R H Feb 19 '17 at 23:40
  • Yeah, I tried leaving the two lines in the interfaces file but still doesn't work, I added two cat outputs to the question. – Diego Shierra Costa Feb 20 '17 at 1:01
  • @RH actually you can connect to wifi and ethernet at the same time. But you do need to set which one gets preference when both are connected which is usually ethernet because it's faster. – WinEunuuchs2Unix Feb 20 '17 at 3:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.