I have two Logitech T620 touch mice that I love. They have a touchpad type surface that can be clicked with the following actions:

  • click on left: mouse button 1
  • click on right: mouse button 3
  • click middle lower: mouse button 2
  • vertical swipe: scroll (buttons 4&5)

The mouse has a number of other swipe features, like two-finger swiping, that do not work under Ubuntu, and I have been fine with that.

Unfortunately, just recently one of the mice stopped scrolling on Ubuntu (but still works on my Windows machine at work).

So I swapped the T620 I was using on my Windows machine with my Ubuntu machine, and I had scrolling on Ubuntu again.

And then a few days later it suddenly stopped scrolling.

I have tried:

  • Using the mouse on my Windows machine (where scrolling works) and connecting and disconnecting the mouse from the "Logitech Unifying Receiver".
  • Turning on and off scrolling on the Windows machine to see if it effects scrolling on Ubuntu
  • Looking at the button map in 'xinput list-props' - it shows a full list of buttons.
  • Installing 'solaar' and connecting/disconnecting the mouse in Ubuntu
  • Running xinput test and evtest, both show no events when scrolling, but buttons 1-3 show up fine

All to no avail.

How can I get vertical scroll to work on my xinput device again? It works fine when I plug the device into Windows, but Windows is a nightmare, so help me use it under Ubuntu! :)

Incidentally, here's the output of list-props:

    Device 'Logitech T620':
            Device Enabled (139):   1
            Coordinate Transformation Matrix (141): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
            Device Accel Profile (270):     0
            Device Accel Constant Deceleration (271):       1.000000
            Device Accel Adaptive Deceleration (272):       1.000000
            Device Accel Velocity Scaling (273):    10.000000
            Device Product ID (257):        1133, 16423
            Device Node (258):      "/dev/input/event5"
            Evdev Axis Inversion (274):     0, 0
            Evdev Axes Swap (276):  0
            Axis Labels (277):      "Rel X" (149), "Rel Y" (150), "Rel Horiz Wheel" (267), "Rel Dial" (268), "Rel Vert Wheel" (269)
            Button Labels (278):    "Button Left" (142), "Button Middle" (143),
                    "Button Right" (144), "Button Wheel Up" (145), "Button Wheel Down"
                    (146), "Button Horiz Wheel Left" (147), "Button Horiz Wheel Right"
                    (148), "Button Side" (262), "Button Extra" (263), "Button Forward"
                    (264), "Button Back" (265), "Button Task" (266), "Button Unknown"
                    (260), "Button Unknown" (260), "Button Unknown" (260), "Button
                    Unknown" (260), "Button Unknown" (260), "Button Unknown" (260),
                    "Button Unknown" (260), "Button Unknown" (260), "Button Unknown"
                    (260), "Button Unknown" (260), "Button Unknown" (260), "Button Unknown" (260)
            Evdev Scrolling Distance (279): 1, 1, 1
            Evdev Middle Button Emulation (280):    0
            Evdev Middle Button Timeout (281):      50
            Evdev Third Button Emulation (282):     0
            Evdev Third Button Emulation Timeout (283):     1000
            Evdev Third Button Emulation Button (284):      3
            Evdev Third Button Emulation Threshold (285):   20
            Evdev Wheel Emulation (286):    1
            Evdev Wheel Emulation Axes (287):       0, 0, 4, 5
            Evdev Wheel Emulation Inertia (288):    10
            Evdev Wheel Emulation Timeout (289):    200
            Evdev Wheel Emulation Button (290):     3
            Evdev Drag Lock Buttons (291):  0
up vote 2 down vote accepted

Just got it working again!

First of all I installed the libinput driver. Don't know if this is a requirement or not:

% sudo apt-get install xserver-xorg-input-libinput

But restarting X didn't solve the problem.

Then I had X dump it's configuration. Evidently the auto-config doesn't work, but dumping the config and using that seems to make things work. So:

% sudo X :1 -configure
% sudo mv ~/xorg.conf.new /etc/X11/xorg.conf

Then I restarted and presto! My mouse could scroll again!


And then it broke again.

But I believe I have fixed it again - I removed 'unity' from my packages (I never liked Unity anyways and was often turning it off - perhaps the scroll support when Unity is installed only works when running unity?)

  • In fact, even button 6 and 7 work now, giving me horizontal scrolling! Joy! – David Ljung Madison Mar 5 '17 at 3:19
  • Okay - so it comes and goes. And at this point my guess is that switching the mouse to a Windows machine and then switching back to Ubuntu seems to fix it (at least via my usb A-B switch where it never drops power). Bummer – David Ljung Madison Aug 8 at 8:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.