0

I have been having issues with networking for a very long time. The worst is when I am at home but there are also issues at school sometimes. I'll start from the beginning.

I first started having issues when I moved in with my family. I had Windows 10 and the wifi would sometimes disconnect. I installed ubuntu 16.04 on that laptop and still had issues connecting and with random network drops. At this point, `sudo service network-manager restart' usually works for a short time, but then it starts acting up again an hour or two later. I assumed at this point the issue was with my wireless card and I went out and bought a new laptop.

EDIT: also note that at this point I had no issues when I was on campus or if I used the mobile hotspot on my phone or tablet. It was only the home router that refused to stay connected).

I am now on a dell laptop that is specifically listed as being compatible with Ubuntu (a Dell Latitude E6420). I immediately installed Ubuntu 16.04. At this point the only issue with networking was the occasional network drop and reconnect, usually after coming back from suspend.

I upgraded to Ubuntu Gnome 16.10 and the issues got worse. Now I am back to Ubuntu Gnome 16.04 and nothing is getting better.

I have tried using wicd but wicd doesn't even connect to the network unless network-manager is running, and even then it doesn't make a difference. This seems to be the only solution anybody can come up with. I don't know what commands to use to get more information so let me know and I will tell you what you need.

$ ifconfig
eno1      Link encap:Ethernet  HWaddr e0:db:55:dd:5a:82  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Memory:e6e00000-e6e20000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:9454 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9454 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:709546 (709.5 KB)  TX bytes:709546 (709.5 KB)

wlp3s0    Link encap:Ethernet  HWaddr 84:3a:4b:56:4a:9e  
          inet addr:192.168.0.17  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::5f18:be7:8291:2b8f/64 Scope:Link
          inet6 addr: 2607:fcc8:6a41:3900:36b3:fd71:a6b3:97bf/64 Scope:Global
          inet6 addr: 2607:fcc8:6a41:3900:4545:66d0:48b:b8e2/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:25275 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17066 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:27895660 (27.8 MB)  TX bytes:2478205 (2.4 MB)

$ sudo lshw -C network
[sudo] password for guinevere: 
  *-network               
       description: Ethernet interface
       product: 82579LM Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eno1
       version: 04
       serial: e0:db:55:dd:5a:82
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.13-3 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:30 memory:e6e00000-e6e1ffff memory:e6e80000-e6e80fff ioport:5080(size=32)
  *-network
       description: Wireless interface
       product: Centrino Advanced-N 6205 [Taylor Peak]
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 34
       serial: 84:3a:4b:56:4a:9e
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.8.0-36-generic firmware=18.168.6.1 ip=192.168.0.17 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:29 memory:e6d00000-e6d01fff
  • I don't what type of wifi card you have but it might be worth disabling the n option of the IEEE802.11 and the power management. – Harris Feb 19 '17 at 22:50
  • I uninstalled power management a few hours ago and haven't lost power since, we'll know by morning whether that was the solution. as for disabling the n option, how do I do that? – Guinevere Ellen Mayberry Feb 19 '17 at 23:24
  • Do you know which driver your wifi card is using ? You can amend your question with the information from the following command: sudo lshw -C network – Harris Feb 19 '17 at 23:50
  • updated with the network output – Guinevere Ellen Mayberry Feb 20 '17 at 0:13
  • okay so network-manager just crashed again, simply uninstalling power management wasn't enough. disabling the n option is next attempt (soon as you see this and let me know the command lol). – Guinevere Ellen Mayberry Feb 20 '17 at 1:14
0

It might be worth disabling the n option of the IEEE802.11 and the power management.

The instructions on how to achieve this can be found in the link below under the Force Disable 802.11n heading.

https://www.linux.com/learn/tips-and-tricks-get-most-out-your-linux-wifi

  • 2
    I recommend editing this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on AskUbuntu.) – David Foerster Feb 24 '17 at 12:26
0

I have a hunch your computer is going in to sleep and loosing network after it wakes up. This is a common "bug" in 16.04 and can be solved in many ways. I will show you one:

Open a terminal by pressing Ctrl+Alt+T.

Now enter the following commands:

sudo cp /lib/systemd/system-sleep/hdparm /lib/systemd/system-sleep/reset-network
sudo chmod 755 /lib/systemd/system-sleep/reset-network
sudo nano /lib/systemd/system-sleep/reset-network

Edit the file to look like this:

#!/bin/sh    
case "$1" in
  post)
    exec /bin/systemctl restart network-manager
    ;;
esac

Your network manager will automatically restart after sleep.

  • there's no way for me to make sure it works right away so I'll let you know later tonight if i'm still experiencing an issue – Guinevere Ellen Mayberry Feb 19 '17 at 19:36
  • update, network-manager just crashed again, so no luck :( – Guinevere Ellen Mayberry Feb 19 '17 at 19:52
  • Im sorry, could it be something with the router/AP. Since you had this problem with two different Computers and two different OS's ? – Izzno Feb 19 '17 at 19:55
  • i know the router itself is fine because my cousin and I are the only ones with the issue. However, one thing that came up prior to this was just how awful WPA/WPA2 is, and that's what the security is on the router, which would explain why the laptops are the only ones with issues (the xbox one, both tvs, and the desktop all connect with no issue). – Guinevere Ellen Mayberry Feb 19 '17 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.