0

Ubuntu 16.04 Install is failing with the following message:

error: unknown flag 'classic'

Performing a 'sudo snap install install conjure-up --beta' fails with the message:

error: cannot perform the following tasks:
- Make snap "ubuntu-core" available to the system (no state entry for key)
- Mount snap "conjure-up" (snap "conjure-up" requires classic or confinement override)
  • sudo snap install conjure-up --beta --classic error: unknown flag `classic' – Stuart Feb 19 '17 at 15:44
  • sudo snap install conjure-up --beta 75.28 MB / 75.28 MB [======================================] 100.00 % 4.88 MB/s error: cannot perform the following tasks: - Make snap "ubuntu-core" available to the system (no state entry for key) - Mount snap "conjure-up" (snap "conjure-up" requires classic or confinement override) – Stuart Feb 19 '17 at 15:46
  • Corrected unknown flag 'classic' error after executing the below: – Stuart Feb 19 '17 at 15:59
  • sudo apt update && sudo apt upgrade && sudo apt dist-upgrade – Stuart Feb 19 '17 at 15:59
0

You'll want to make sure you're running snapd version 2.21 or later. A simple

sudo apt-get update
sudo apt-get upgrade

Should correct this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.