I'm currently trying to dual boot Ubuntu 16.10 alongside Windows 10 on a Dell XPS 13 (series 7).

I've basically followed this guide! which involves:

  1. Changing from IDE to AHCI mode
  2. Enabling 'UEFI Network Stack' via the BIOS
  3. Booting via USB - (with Ubuntu Boot disk created via Rufus or Etcher)
  4. Installing Ubuntu via USB

Install hums along as per usual until it comes to installing Grub where it shows an error:

"The 'grub-efi-amd64-signed' package failed to install into /target/.
Without the GRUB boot load, the installed system will not boot."

This is a new laptop so I haven't installed Ubuntu on the machine yet, but I have installed it on old laptops and am reasonably familiar with the setup process so I've tried a number of alternative solutions including: - ensuring updates are downloaded during the install - specifying the install partitions for the root, swap and boot - Installing via DVD instead of USB - Making a sandwich

Anyway, I haven't had any luck and would be grateful for suggestions/ideas as after a lot of googling I'm out of them.


Okay, so I've managed to get it working after a lot of trial and error.

Unfortunately I'm not sure if it provides useful information for others who might experience the same issue.

Here are the steps I took:

  1. Suspecting it may be an issue with Ubuntu 16.10, I undertook the painful process of downloading 16.04 (LTS). - painful due to my slow internet -
  2. I updated my BIOS and Hard drive (Toshiba NVMe) firmware from the Dell website (Dell XPS 13 9360).
  3. Delete the old ubuntu EFI entries via Windows (in case it was causing the error).
  4. Installing Ubuntu 16.04 via USB (UEFI mode) - made it past previous GRUB error above, but received error "'grub-install /dev/nvme failed. This is a fatal error.'". Installation halted.
  5. Launched live-usb and repaired grub via 'Boot Repair' with 'secure-boot' unchecked in the 'advanced' option.

This worked.

No idea if my computer is likely to explode, but everything seems fine.

Btw, this has been reported by a number of other users eg example 1 and example 2


One other thing I had to do (possibly as the install halted early) was check and replace/repair missing files via instructions below: Find (and reinstall) packages with corrupted files (without breaking anything)

  • Please run the Boot Info Script. This will generate a file called RESULTS.txt. Post that file to a pastebin site and post the URL to your document here. This will give us more details about your configuration, which is required to base an answer on more than guesswork.
    – Rod Smith
    Feb 20, 2017 at 23:21
  • Thanks for this Rod. I did try to do this, but I couldn't get it to work for the latest install. Still, here is a link to to the latest one I could get to work.
    – Giles
    Feb 22, 2017 at 11:53
  • please see my answer, below.
    – Rod Smith
    Feb 22, 2017 at 14:44

1 Answer 1


I suspect that the problem is related to the fact that your computer is using an NVMe "disk" device. Such devices are still new enough that they cause problems for many tools. My hypothesis is that the Ubuntu installer, or a tool on which it relies, is becoming confused by the NVMe device and so is failing to install correctly. The Boot Info Script that you ran seems to be a bit confused, too, so I'm working on incomplete information -- but I do have enough to suggest a workaround:

  1. If you haven't already done so, disable Secure Boot.
  2. Download the USB flash drive of my rEFInd boot manager. (There are download links for a USB image on that page.)
  3. Prepare a USB flash drive with rEFInd.
  4. Boot the USB flash drive with rEFInd. You should see the rEFInd menu, and it should show options to boot both Ubuntu and Windows.
  5. Select the Ubuntu boot option in rEFInd. With any luck, Ubuntu will boot up.
  6. If Ubuntu boots, download the latest test/development version of rEFInd using this link. That's a Debian package that you can install by typing sudo dpkg -i refind_0.10.4.2-0ppa1_amd64.deb from the directory in which it resides. Note that I'm specifying you use this version because it includes some fixes for NVMe-related issues in the installer. The older official release version (0.10.4) might work, but this one's fixes might be required for you. Anybody reading this much past February 22, 2017 should check the main rEFInd page (above) to see if a newer version is available and, if one is, use it instead.
  7. Reboot and hope for the best.

With any luck, your system will boot up to rEFInd, which should enable you to boot either Windows or Ubuntu. Note, however, that I can't promise this procedure will work; there are any number of points where it might fail. If you run into problems, please feel free to post back with more details.

Instead of installing rEFInd in step #6, you could try installing GRUB manually by typing sudo grub-install; however, whatever problem blocked the GRUB installation in the installer is likely to block this procedure, too, which is why I recommended installing rEFInd above. You could try this, though, if you prefer to use GRUB. If nothing else, installing GRUB from the console in this way is likely to produce better error messages than what the Ubuntu installer produced.

  • 1
    Thanks Rod. Really appreciate your quick response. I'm obviously new to Linux, but I think you're right that it's an issue with the NVMe disk. The 'Boot Repair' workaround seemed to work, so Ubuntu is now booting okay, but I think your solution will undoubtedly be helpful for others facing this issue.
    – Giles
    Feb 22, 2017 at 15:46
  • 1
    Ah, OK. I didn't notice you'd updated your question with the solution you found. You can move that to an answer and approve it yourself, if you like.
    – Rod Smith
    Feb 22, 2017 at 15:51
  • Well this seems like a common problem which I think your solution might provide a more reliable solution for so I'm not sure if it's better to leave it as the preferred solution until others trial it?
    – Giles
    Feb 25, 2017 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.