1

I am running Ubuntu 16.04 on Dell XPS 13 Intel HD Graphics 520 connected to Razer Core through its USB Thunderbolt that has Nvidia GTX1060 for powering a full HD external display. I have installed latest nvidia driver (378.13) from PPA repository and update the system and able to make a mirror displays on my internal and external screen. So I assume the eGPU setup is working well as it ables to run both displays in mirrors mode.

But the problem is once I unchecked the Mirror displays to make an extended displays, the display becomes stretched like this:

stretched desktop screenshot

Left side is my external display and right side is my internal display. When I click somewhere on desktop area with my mouse, it is not clicking at the right location. It seems due to the incorrect resolution. But I can still click properly the sidebar and top bar menu (wireless, time, settings).

I have tried different nvidia drivers that available to be installed, i.e 367.57, 370.28, and 375.39 but have no difference. The configuration in nvidia-settings is set to default, I did not change anything there.

EDIT: I am adding screenshot for nvidia-settings and Screen Display settings:

nvidia-settings and Screen Display settings

In Selection option, there are X screen 0, Anchor Communication, and PRIME Display. I am not sure if my internal display should be listed there, but I can see my internal and external display in Screen Display settings.

  • What happens if you set the Scaling control to "display with largest controls" ? I'm not saying that will solve your problems, just curious. – Jos Feb 19 '17 at 12:08
  • Hey @Jos I tried that option and it makes no difference. The other options also do nothing. I am adding my nvidia-settings and Screen Display settings. – spondbob Feb 19 '17 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.