1

I am using a VPN connection and a remote desktop client called Rammina. The VPN is successfully connected and I am able to connect remotely to a windows server using a Remote Desktop Protocol (I put the Server = DNS server IP address). However, when I enter the IP address of a remote desktop (Windows 10), I have the following error message: Unable to connect to the RDP server

Can you please advise?

**Note: I am able to connect remotely from a Windows to Windows.

Solution: Security had to be set to Negotiate and the user name was incorrect

1

Whenever this happens to me deleting all the Remmina RDP certificates gets it back up and running.

The certificates are located at ~/.freerdp/known_hosts/

rm -rf ~/.freerdp/known_hosts/*

It is nothing dangerous, you will just need to re-confirm connection to the remote pc with a yes/no question at next attempt. Other than this little bug I find Remmina to be an excellent remote connection tool, never had any other Remmina related problems.

  • I tried this method but i have the same issue. – Zimo Feb 18 '17 at 22:11
  • If you connect to the DNS server and then from the DNS server to the Windows 10 machine can you establish a successful connection? Also can you ping the Windows 10 directly from your PC? And finally, are you able to get a Windows-Windows remote connection over the VPN or only when in the same LAN? – Louis Papaloizou Feb 18 '17 at 22:17
  • On the Remmina side of things I find only one more probable cause. Right click your connection, select Edit, in the Advanced tab select RDP for the Security option (the default is negotiate). – Louis Papaloizou Feb 18 '17 at 22:25
  • -RDP is selected for the Security option. -I am able to get a Windows-Windows remote connection over the VPN (i have windows7 installed inside Linux using virtual box, and i am able to connect to the other PC (Windows10)). Since i have access to the other PC over VPN when i use windows, i am able to ping. – Zimo Feb 18 '17 at 22:37
  • Note: I have the same issue with Remote Desktop Viewer – Zimo Feb 18 '17 at 22:48
1

Problem Solved!. Bellow are the following issues:

1) Security had to be set to Negotiate. It is not working with RDP.

2) My user name was incorrect: i was using domain_name\my_user_name instead of simply using my_user_name

**Note: Color depth was not the problem. All of the settings are working.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.