0

I can't use VirtualBox. When I tried to create a ubuntu in it, after powering the virtual box on it gives this as output. Failed to open a session for the virtual machine Ubuntu GNOME.

VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Please help me fix this.

  • What do you mean by powering virtual box? Do you mean powering the Ubuntu vm you created? Also do you have virtualization active on your computer? – LnxSlck Feb 18 '17 at 15:16
  • 1
    VT-x is disabled in the BIOS for all CPU modes, means disabled in the BIOS. Go and check it – M. Becerra Feb 18 '17 at 15:21
2

First you have to make sure that your cpu supports VT-x aka virtualization.

Go to intel's website and and type your cpu's name and find the specifications and see if VT-x is supported by your cpu.

If is supported enter your bios and search for a option named VT-x virtualization or intel virtualization or just virtualization and enable that and try again virtualbox.

If your cpu supports intel's VT-d known simply as KVM there is a high chance that you missing a huge privilege, for details please see HERE.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.