2

I have an Asus x55l laptop. I hooked up my laptop to my TV and the video works fine. However the audio is played through my laptop. I tried changing the audio settings to play through HDMI, but upon testing there was no sound. I tried changing configuration on pulseaudio and still no sound.

Here is my aplay -l output:

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]  Subdevices: 1/1
  Subdevice #0: subdevice #0

card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

card 1: PCH [HDA Intel PCH], device 0: ALC3236 Analog [ALC3236 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

and here is my pacmd list-cards ouptut:

2 card(s) available.
    index: 0
   name: <alsa_card.pci-0000_00_03.0>
   driver: <module-alsa-card.c>
   owner module: 6
   properties:
      alsa.card = "0"
      alsa.card_name = "HDA Intel HDMI"
      alsa.long_card_name = "HDA Intel HDMI at 0xf721c000 irq 51"
      alsa.driver_name = "snd_hda_intel"
      device.bus_path = "pci-0000:00:03.0"
      sysfs.path = "/devices/pci0000:00/0000:00:03.0/sound/card0"
      device.bus = "pci"
      device.vendor.id = "8086"
      device.vendor.name = "Intel Corporation"
      device.product.id = "160c"
      device.product.name = "Broadwell-U Audio Controller"
      device.form_factor = "internal"
      device.string = "0"
      device.description = "Built-in Audio"
      module-udev-detect.discovered = "1"
      device.icon_name = "audio-card-pci"
   profiles:
      output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5400, available: unknown)
      output:hdmi-surround: Digital Surround 5.1 (HDMI) Output (priority 300, available: unknown)
      output:hdmi-surround71: Digital Surround 7.1 (HDMI) Output (priority 300, available: unknown)
      output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5200, available: unknown)
      output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 100, available: unknown)
      output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5200, available: unknown)
      output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 100, available: unknown)
      output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 100, available: unknown)
      off: Off (priority 0, available: unknown)
   active profile: <output:hdmi-stereo-extra1>
   sinks:
      alsa_output.pci-0000_00_03.0.hdmi-stereo-extra1/#0: Built-in Audio Digital Stereo (HDMI 2)
   sources:
      alsa_output.pci-0000_00_03.0.hdmi-stereo-extra1.monitor/#0: Monitor of Built-in Audio Digital Stereo (HDMI 2)
   ports:
      hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
         properties:
            device.icon_name = "video-display"
      hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
         properties:
            device.icon_name = "video-display"
      hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
         properties:
            device.icon_name = "video-display"
    index: 1
   name: <alsa_card.pci-0000_00_1b.0>
   driver: <module-alsa-card.c>
   owner module: 7
   properties:
      alsa.card = "1"
      alsa.card_name = "HDA Intel PCH"
      alsa.long_card_name = "HDA Intel PCH at 0xf7218000 irq 50"
      alsa.driver_name = "snd_hda_intel"
      device.bus_path = "pci-0000:00:1b.0"
      sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card1"
      device.bus = "pci"
      device.vendor.id = "8086"
      device.vendor.name = "Intel Corporation"
      device.product.id = "9ca0"
      device.product.name = "Wildcat Point-LP High Definition Audio Controller"
      device.form_factor = "internal"
      device.string = "1"
      device.description = "Built-in Audio"
      module-udev-detect.discovered = "1"
      device.icon_name = "audio-card-pci"
   profiles:
      input:analog-stereo: Analog Stereo Input (priority 60, available: unknown)
      output:analog-stereo: Analog Stereo Output (priority 6000, available: unknown)
      output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6060, available: unknown)
      off: Off (priority 0, available: unknown)
   active profile: <output:analog-stereo+input:analog-stereo>
   sinks:
      alsa_output.pci-0000_00_1b.0.analog-stereo/#1: Built-in Audio Analog Stereo
   sources:
      alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#1: Monitor of Built-in Audio Analog Stereo
      alsa_input.pci-0000_00_1b.0.analog-stereo/#2: Built-in Audio Analog Stereo
   ports:
      analog-input-mic: Microphone (priority 8700, latency offset 0 usec, available: unknown)
         properties:
            device.icon_name = "audio-input-microphone"
      analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: unknown)
         properties:
            device.icon_name = "audio-speakers"
      analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: no)
         properties:
            device.icon_name = "audio-headphones"
  • The 'active profile' of your HDMI card is hdmi-stereo-extra1, which is connected to HDMI2. Are you sure this is the right HDMI port? Try with profiles hdmi-stereo or hdmi-stereo-extra2. You may also activate simultaneous outputin paprefsand select this virtual output in pavucontrolto see if it works. – ridgy Feb 18 '17 at 10:48
  • I tried both hdmi-stereo and hdmi-stereo-extra2 and performed a sound test using sound settings, only my laptops speakers were working. I created simultaneous output as well, and tried out all the profiles, same result. FYI, both hdmi-stereo and hdmi-stereo-extra2 are shown as unplugged in pavucontrol all the time. Only hdmi-stereo seems to show up as plugged in. – Abhilash E Feb 18 '17 at 13:44
  • So the configuration seems OK. Does the 'Playback' tab in pavucontrol show some hint when you are running audio or video application? – ridgy Feb 18 '17 at 13:56
  • Yes it does show up, while playing through application and while performing sound test as well. – Abhilash E Feb 19 '17 at 11:50
  • Start alsamixer, select your HDMI card with F6 and look if the output channels are muted (showing MM at the bottom). And in 'Playback' tab in pavucontrolmake sure the correct output device is chosen for the application. – ridgy Feb 19 '17 at 12:08
-1

I had something similar. Sometimes hdmi sound worked. Sometimes not. Rebooting was the only way to fix it. LOOK for irq selected - your capture has 51 and 50 used. Now go to /proc and look at the interrupts used. I saw them in the text file called interrupts. For me sound worked when interrupts 52 and 51 were listed by pacmd and did not work when interrupts 51 and 50 were used. When 51 and 50 was used by intel hda sound - 52 was used by intel wifi. I checked Settings / Network / wifi. wifi was OFF but airplane mode was ON. Turning off airplane mode AND wifi made hdmi sound work on irq 51 and 50. Rebooting many times results in hda sound on irq 51 and 50 and sound works. For me it appears to be a problem is if wifi is OFF but airplane mode ON, the irq assigned on bootup has a conflict. It would be good if aiplane mode is OFF when wifi is OFF automatically.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.