1

I unpack ubuntu 16.04 iso on my external HDD with GPT (made in Gparted - because of asus UEFI) - everything is fine, but I can't create working persistent storage... I've tried to create the second partition (at the same external HDD in addition to ubuntu partition) with Ext2 (labeled casper-rw) and type "persistent" after "quiet splash" in grub menu before booting, then tried to change grub by using sudo gedit /etc/default/grub and sudo update-grub with needed parameters, but nothing help

After restarting my data and options become default. What I do wrong?

I can't use any automatic programs, because they don't create live iso in GPT, any others partition tables are not working with my Asus UEFI (and I can't find "legacy bios" mode).

Can someone explain how to mount casper-rw or whatever I should do to solve my problem. I want to have live OS on my external HDD with persistent mode permanently and without typing every time "persistent" parameter while loading.

P.S. - Please, don't offer me install full Ubuntu version on my external HDD because after first replugging of this HDD it will never work again and moreover it will crash my Win 10 loader =(

0

here you are https://www.youtube.com/watch?v=1Un0vsw6HKY create iso and after this make persistent usb live with casper-rw

  • The steps are needed not just links as this can change... – George Udosen Feb 20 '17 at 5:30
0

The persistent mode seems to work only from ubuntu precise and before.

Tested by me with Xubuntu 12.04.4 :

1 - Take a usb stick. In your case, take your external HDD plug by usb.

2 - Create a 5 GB ext4 partition named "casper-rw"

3 - Create a 10 GB fat32 partition (theorically with ~6 ,you should be fine). It will contain your extracted iso + a 4.3 GB "casper-rw" file.

4 - Launch Unetbootin, select your ubuntu iso, your fat32 partition and check persistent storage for 5000 Mo(5 GB).

Note: In fact the limit is 4.3 GB , don't ask me why.

It's gonna take a while, don't panic if the unetbootin window go blank.

5 - After the success message in the window, hit quit & go in your fat32 partition, delete the 4.3 GB "casper-rw" file.

Now you can boot on this usb stick persistent.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.