2

I am trying to dualboot a brand new computer - ASUS ZenBook Flip UX360UAK-BB358R with Intel Core i7 7500U Kaby Lake.

The preinstalled Windows 10 Pro work well. After minor testing of the laptop I shrinked the windows partition do half and intended to install Ubuntu aside so that I have a dualboot.

I tried the following systems - Ubuntu 16.04 LTS, Ubuntu 16.10, Ubuntu 17.04 alpha (daily build from 17.2.2017) and KDE Neon (built on Ubuntu 16.04 LTS). To the last one (neon) I also tried to install kernel 4.9.10.

The problem is always the same with all of the systems.

  1. I install the system / to the ext4 partition which I create from the free space that windows shrinkage tool left me, leaving 8GB to swap.
  2. I restart the computer, in grub select Ubuntu (or neon), splashscreen appears and it freezes.
  3. After ~20min I turn of the computer.
  4. I try turning it on again and it works.
  5. [When I log in, I update the whole system, update kernel, disable mounting the windows drives in /etc/fstab]
  6. I reboot again and it works or not. About 1/10 boots works. Windows work everytime.
  7. In 1/2 cases I am able to boot live usb and mount the drive to analyze it.

I also turned off the splashscreen to get this output (sorry for the quality, I don't know how to capture it without using my phone). Sometimes it terminates with kernel panic, sometimes it just freezes like this. Anyway it always passes the grub, starting a splashscreen with a spinner. Then, before log-in screen, the spinner either freezes or runs till infinity of the screen goes black and nothing happens.

I also enclose some common logs (currently running Neon with kernel 4.9.10) but it is very similar in standard ubuntu.

My thoughts:

  • there is a problem with driving the Kaby Lake cpu
  • there are missing some other drivers (however linux-firmware is installed)
  • there is a problem with having windows installed aside
  • it is pretty weird as I tried multiple systems (each multiple-times) and the behavior is still the same

However, all of them contradict the fact that sometimes it boots well. I can't see any pattern when it works and when it doesn't. So far I think it is better chance to boot up if windows were booted before (but it doesn't help always).

I would be very grateful if you could give me some tips on what to do as I am after yestarday 12-hour session pretty desperate. Thanks

EDIT 1:

Following the Teyras's answer, I tried to debug ACPI (tutorial). My results (if I write "everytime" I mean 5/5 tries):

  • acpi=off - boots everytime; neither touchap nor touchscreen works
  • acpi=ht - boots occasionally; if it boots? everything works
  • pci=noacpi - boots everytime; neither keybord nor touchap nor touchscreen works
  • acpi=noirq - doesn't boot
  • pnpacpi=off - doesn't boot
  • noapic - boots everytime; neither keybord nor touchap nor touchscreen works
  • nolapic - boots occasionally; if it boots: neither touchap nor touchscreen works

EDIT 2: Everything is really weird, sometimes acpi=off boots to a normal mode where even touchpad etc. works fine.

I came across to this reddit post in which similar problems are discussed. I tried to turn off the wifi and bluetooth in the grub by pressing fn+F2 as suggested, but the control diode didn't turn on and boot failed, so I guess it doesn't work at all.

closed as off-topic by Elder Geek, Fabby, muru, Zanna, Mark Kirby Mar 1 '17 at 12:36

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – Elder Geek, Fabby, Zanna, Mark Kirby
If this question can be reworded to fit the rules in the help center, please edit the question.

  • We're all a little confused. Are you on Ubuntu, or an unofficial derivative? (KDE Neon isn't a recognized Ubuntu derivative) – Thomas Ward Feb 28 '17 at 3:26
  • I tried all of them. I finally ended up with up-to-date Atchlinux and Floop's suggestions. – 3.14.TR Feb 28 '17 at 7:14
2

Some people seem to have similar issues [1] [2] with recent Intel GPUs. One thing that seems to help is to set kernel boot parameter intel_idle.max_cstate=2 (or even =1). To do that:

  1. Open your /etc/default/grub as root
  2. Add intel_idle.max_cstate=2 to the GRUB_CMDLINE_LINUX_DEFAULT string. For instance,
    GRUB_CMDLINE_LINUX_DEFAULT="quiet intel_idle.max_cstate=2"
  3. Run sudo update-grub (or similar command, depends on your distribution)

The downside is, that your GPU will drain slightly more power even when it is idle.

Furthermore, the stability of the driver is reported to increase if you add:
options i915 semaphores=1 to your /etc/modprobe.d/i915.conf file. To do that, run:
echo "options i915 semaphores=1" >> /etc/modprobe.d/i915.conf

Least but not last, update your BIOS and use the most recent Linux kernel for your distribution.

  • The first advice works fine for me. Btw wIth kernel 4.10.13 (ArchLinux) it seems to be pretty stable even without it. – 3.14.TR May 12 '17 at 18:34
1

First, try booting with the acpi=off nomodeset xforcevesa kernel parameters (add them to the GRUB_CMDLINE_LINUX_DEFAULT variable in /etc/default/grub and run sudo update-grub). If your system boots consistently, try to remove the nomodeset xforcevesa part. If it stops booting, there is a problem with your GPU driver. Otherwise, go through the debugging process described here.

Not the answer you're looking for? Browse other questions tagged or ask your own question.