I have an rtl8814au WiFi chipset that I am trying to get to work with Linux:

  1. I have tried downloading the file (.zip) then
  2. Going in the terminal and changing directory the one that contains the file and then
  3. ./ (filename) to run.
    • I get permission denied error so
  4. I tried chmod +x (filename) then ./ (filename) again and got the error below. I have almost no experience with Linux other than installing it and update and upgrade so any help is greatly appreciated.

    root@Graybox:/home/kryas/Downloads#  ./rtl8814AU-driver-4.3.21.zip
    ./rtl8814AU-driver-4.3.21.zip: line 1: $'PK\003\004': command not found
    ./rtl8814AU-driver-4.3.21.zip: line 2: $'\273\201QI\030': command not found
    ./rtl8814AU-driver-4.3.21.zip: line 8: syntax error near unexpected token `)'
    ./rtl8814AU-driver-4.3.21.zip: line 8: ��QIf����G rtl8814AU-driver- 4.3.21/LICENSEUT2[X�\[s�ȱ~�:?bJy�TE�k�$'�Nm%Q�RH�^�$�"b`0�d����e�/�ŕ�- �����ח��������7u��'���4~��\��$��<K�.]��;�����- �lg~'��oGK�W�*u%��{���y���b�U����{�������a�1���J���г�sg����{к*��2}^W������eoJ���XU�I��MQ�ˤ�����>����b����N���IW���dEQ��e�+"�y`�O޿���������������+wK�ݺr�V�[ڪ�
                                            ph�|i����t^W��+��fC_��[�l�ƛ*2�,�b�Y<o�$N�g�VD>/*�dY���}s����%�y������ޮ��n���T迥��s.�V�7|���쮨K��ņ��k~�`^�˪o��ȫ2�`��Z��e�z��4�\�����r�pF����R��    <�}�G6ħ��-�lKг�Q�<z[{�M�$�zsB���6�)��,>
    O���9���i�q��)m�lnQ@o ���aߥ�2)w�l:�}��e��ڧ���$����0âW�=N�(X���]n_!حK��4X���}E�n�ʒ�  ��H9Ͷ����=����^|�IEZa�ɋ�p�����g�Uw�gVÆ5x��6]i����E�Y'
     root@Graybox:/home/kryas/Downloads# cd /home/kryas/Downloads/rtl8814AU-driver-4.3.21.zip
  • please add link of the download... – George Udosen Feb 18 '17 at 5:41
  • The most recent version of the drivers that I could find and worked for me were those from aircrack-ng. There are simple instructions in the README. Worked for me using Asus AC68 dongle on Ubuntu 16.04 using kernel 4.15. – n1k31t4 Feb 18 '18 at 16:13

I suggest that you get a temporary working internet connection by ethernet, tether or whatever means possible. Open a terminal and do:

sudo apt-get update
sudo apt-get install git dkms
git clone https://github.com/sbosshardt/rtl8814AU.git
cd rtl8814AU
sudo ./dkms-install.sh

Reboot with the device inserted and your wireless should be working.

Reference: https://github.com/sbosshardt/rtl8814AU

  • Unfortunatly this driver does not accept monitor mode: command failed: Operation not supported (-95) – SuB Oct 9 '17 at 9:55
  • Ubuntu 16.04LTS. Worked like a charm! Same speed as for WIndows 10. – mattias Nov 4 '17 at 11:14
  • I had to get zebulon2's fork to get it to compile on Linux 4.13. – z0r Apr 11 '18 at 4:08

You have to first extract the zip file and then run make and make install but the previous driver should be removed first.

The steps should be:

  • Download the driver and place it on your Desktop

  • Then, in the terminal application, do the following (in blue)...

    • cd ~/Desktop # change to the Desktop directory

    • unzip rtl8814AU-driver-4.3.21.zip # uncompress the .zip file

    • cd rtl8814AU-driver-4.3.21 # change directory to the unzipped files

    • make # compile the driver

    • sudo modprobe -rv rtl8814au # remove any currently installed driver

    • sudo make install # install the new driver

    • sudo modprobe -v rtl8814au # load the new driver

  • Done! Plug in your wireless adapter.

  • 1
    Good job George. I'd add step 1.1 "In terminal..., and I'd change step 2/4 to "Change directory to...". cd ~/Desktop/rtl8814AU-driver-4.3.21 etc. +1 vote – heynnema Feb 18 '17 at 14:28
  • @heynnema, I don't seem to able to get the 1.1 addition your suggesting please could you be kind enough to make the changes. – George Udosen Feb 18 '17 at 16:31
  • Does that look OK to you? ps: this assumes the non-dkms version – heynnema Feb 18 '17 at 16:43
  • Thanks for all the help guys i cant really tell who was right as i kept getting errors but i decided to plig it in and it work... i wonder if ubuntu da the and just added the driver? – Kryas Feb 21 '17 at 0:53
  • Most probably a glitch that corrected it self, great its ok now... – George Udosen Feb 21 '17 at 1:26

I took sbosshardt's work as foundation, merged changes from other forks and applied some other tweaks in my fork here: https://github.com/nazar-pc/RTL8814AU

Readme contains easy to follow instructions on how to install or remove the driver. Currently this is the most up to date working driver I know, it should work on modern kernels up to 4.14-rc2 (probaly even further).

  • Unfortunatly this driver does not accept monitor mode: command failed: Operation not supported (-95) – SuB Oct 9 '17 at 10:36
  • 2
    Yeah, there is no single perfect driver for any use case yet. For monitor mode I'd suggest a fork by aircrack-ng developer: github.com/aircrack-ng/rtl8812au – nazar-pc Oct 9 '17 at 14:39
  • @nazar-pc I am trying to use your driver, but I only get 0-2MB/s this is on Ubuntu 18.04.2 LTS. Do we need to tell it to use USB3 or is that part of the driver? – Mech0z May 11 '19 at 20:34
  • This is with DWA-192, in the same room as my router, my windows pc got 300+ Mbit in a room futher away. And it seems to use USB3 according to this "Port 1: Dev 5, If 0, Class=Vendor Specific Class, Driver=rtl8814au, 5000M" – Mech0z May 11 '19 at 21:09
  • I'm not owning my own device for a long time now, can't suggest anything specific. But I was getting hundreds of Mbps back then for sure. – nazar-pc May 12 '19 at 0:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.