1

I recently installed Xubuntu 16.04 on my system, alongside Windows 7. The installation/live USB worked fine without any problems.

However, my system erratically suspends without warning. No data is lost, but suspending approximately every 2 minutes is very annoying.

This is a very old 32-bit laptop, with no internal battery, Pentium 4 processor, ATI Radeon graphics card. Works very nicely, except for this one little problem.

How do I fix this?

UPDATE: Apparently using systemd-inhibit solves it but only while it's running.

Here is some of the output from dmesg:

[ 1014.283131] PM: Syncing filesystems ... done.
[ 1015.409901] PM: Preparing system for sleep (mem)
[ 1015.410185] Freezing user space processes ... (elapsed 0.002 seconds) done.
[ 1015.412911] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[ 1015.414307] PM: Suspending system (mem)
[ 1015.414337] Suspending console(s) (use no_console_suspend to debug)
[ 1015.414766] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[ 1015.790285] sd 0:0:0:0: [sda] Stopping disk
[ 1016.178846] PM: suspend of devices complete after 764.219 msecs
[ 1016.179369] PM: late suspend of devices complete after 0.516 msecs
[ 1016.180038] ohci-pci 0000:00:13.1: System wakeup enabled by ACPI
[ 1016.180048] ehci-pci 0000:00:13.2: System wakeup enabled by ACPI
[ 1016.180072] ohci-pci 0000:00:13.0: System wakeup enabled by ACPI
[ 1016.196043] PM: noirq suspend of devices complete after 16.668 msecs
[ 1016.196225] ACPI: Preparing to enter system sleep state S3
[ 1016.197296] ACPI : EC: EC stopped
[ 1016.197299] PM: Saving platform NVS memory
[ 1016.197372] Disabling non-boot CPUs ...
[ 1016.197699] Broke affinity for irq 1
[ 1016.197705] Broke affinity for irq 9
[ 1016.197709] Broke affinity for irq 12
[ 1016.197712] Broke affinity for irq 14
[ 1016.197714] Broke affinity for irq 15
[ 1016.197718] Broke affinity for irq 16
[ 1016.197721] Broke affinity for irq 17
[ 1016.197725] Broke affinity for irq 18
[ 1016.197728] Broke affinity for irq 19
[ 1016.198943] smpboot: CPU 1 is now offline
[ 1016.208365] ACPI: Low-level resume complete
[ 1016.208365] ACPI : EC: EC started
[ 1016.208365] PM: Restoring platform NVS memory
[ 1016.208365] Enabling non-boot CPUs ...
[ 1016.228650] x86: Booting SMP configuration:
[ 1016.228653] smpboot: Booting Node 0 Processor 1 APIC 0x1
[ 1016.198774] Initializing CPU#1
[ 1016.242484]  cache: parent cpu1 should not be sleeping
[ 1016.243003] CPU1 is up
[ 1016.244592] ACPI: Waking up from system sleep state S3
[ 1016.245621] ohci-pci 0000:00:13.0: System wakeup disabled by ACPI
[ 1016.245672] ohci-pci 0000:00:13.1: System wakeup disabled by ACPI
[ 1016.260277] ehci-pci 0000:00:13.2: System wakeup disabled by ACPI
[ 1016.260455] PM: noirq resume of devices complete after 15.044 msecs
[ 1016.260920] PM: early resume of devices complete after 0.425 msecs
[ 1016.265353] [drm] AGP mode requested: 8
[ 1016.265362] agpgart-ati 0000:00:00.0: AGP 3.0 bridge
[ 1016.265386] agpgart-ati 0000:00:00.0: putting AGP V3 device into 8x mode
[ 1016.265421] radeon 0000:01:05.0: putting AGP V3 device into 8x mode
[ 1016.265472] radeon 0000:01:05.0: GTT: 32M 0xD2000000 - 0xD3FFFFFF
[ 1016.266034] sd 0:0:0:0: [sda] Starting disk
[ 1016.276516] radeon 0000:01:05.0: WB disabled
[ 1016.276525] radeon 0000:01:05.0: fence driver on ring 0 use gpu addr 0x00000000d2000000 and cpu addr 0xf8428000
[ 1016.276572] [drm] radeon: ring at 0x00000000D2001000
[ 1016.276623] ACPI Error: No handler for Region [ECR_] (f6434960) [EmbeddedControl] (20150930/evregion-163)
[ 1016.276628] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20150930/exfldio-297)
[ 1016.276646] ACPI Error: Method parse/execution failed [\_SB.EPWR.PCLK] (Node f6488858), AE_NOT_EXIST (20150930/psparse-542)
[ 1016.276662] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPC0.EC0._Q1E] (Node f648e930), AE_NOT_EXIST (20150930/psparse-542)
[ 1016.276689] [drm] ring test succeeded in 0 usecs
[ 1016.276708] [drm] ib test succeeded in 0 usecs
[ 1016.292149] rtc_cmos 00:00: System wakeup disabled by ACPI
[ 1016.320062] usb usb3: root hub lost power or was reset
[ 1016.324093] usb usb2: root hub lost power or was reset
[ 1016.489106] ata2.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[ 1016.489111] ata2.00: ACPI cmd ef/03:42:00:00:00:a0 (SET FEATURES) filtered out
[ 1016.504639] ata2.00: configured for UDMA/33
[ 1016.608212] PM: resume of devices complete after 347.276 msecs
[ 1016.609709] PM: Finishing wakeup.
[ 1016.609712] Restarting tasks ... done.
[ 1016.824199] firewire_core 0000:02:00.0: rediscovered device fw0
[ 1017.384432] ata1.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[ 1017.384447] ata1.00: ACPI cmd ef/03:45:00:00:00:a0 (SET FEATURES) filtered out
[ 1017.392629] ata1.00: configured for UDMA/100
[ 1017.521001] IPv6: ADDRCONF(NETDEV_UP): enp2s3: link is not ready
[ 1017.521223] 8139too 0000:02:03.0 enp2s3: link down
[ 1017.522491] IPv6: ADDRCONF(NETDEV_UP): enp2s3: link is not ready
[ 1017.543690] IPv6: ADDRCONF(NETDEV_UP): wlp2s2: link is not ready
[ 1017.568506] IPv6: ADDRCONF(NETDEV_UP): wlp2s2: link is not ready
[ 1017.689485] IPv6: ADDRCONF(NETDEV_UP): wlp2s2: link is not ready
[ 1045.519238] PM: Syncing filesystems ... done.
[ 1046.362006] PM: Preparing system for sleep (mem)
[ 1046.362307] Freezing user space processes ... (elapsed 0.002 seconds) done.
[ 1046.365094] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[ 1046.366520] PM: Suspending system (mem)
[ 1046.366553] Suspending console(s) (use no_console_suspend to debug)
[ 1046.366999] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[ 1046.581747] sd 0:0:0:0: [sda] Stopping disk
[ 1046.966257] PM: suspend of devices complete after 599.412 msecs
[ 1046.966777] PM: late suspend of devices complete after 0.514 msecs
[ 1046.967410] ehci-pci 0000:00:13.2: System wakeup enabled by ACPI
[ 1046.967412] ohci-pci 0000:00:13.1: System wakeup enabled by ACPI
[ 1046.967443] ohci-pci 0000:00:13.0: System wakeup enabled by ACPI
[ 1046.980119] PM: noirq suspend of devices complete after 13.337 msecs
[ 1046.980301] ACPI: Preparing to enter system sleep state S3
[ 1046.981366] ACPI : EC: EC stopped
[ 1046.981368] PM: Saving platform NVS memory
[ 1046.981437] Disabling non-boot CPUs ...
[ 1046.981755] Broke affinity for irq 1
[ 1046.981761] Broke affinity for irq 9
[ 1046.981765] Broke affinity for irq 12
[ 1046.981768] Broke affinity for irq 14
[ 1046.981771] Broke affinity for irq 15
[ 1046.981774] Broke affinity for irq 16
[ 1046.981777] Broke affinity for irq 17
[ 1046.981781] Broke affinity for irq 18
[ 1046.981784] Broke affinity for irq 19
[ 1046.982998] smpboot: CPU 1 is now offline
[ 1046.992360] ACPI: Low-level resume complete
[ 1046.992360] ACPI : EC: EC started
[ 1046.992360] PM: Restoring platform NVS memory
[ 1046.992360] Enabling non-boot CPUs ...
[ 1047.012660] x86: Booting SMP configuration:
[ 1047.012663] smpboot: Booting Node 0 Processor 1 APIC 0x1
[ 1046.982830] Initializing CPU#1
[ 1047.026628]  cache: parent cpu1 should not be sleeping
[ 1047.027161] CPU1 is up
[ 1047.028767] ACPI: Waking up from system sleep state S3
[ 1047.029800] ohci-pci 0000:00:13.0: System wakeup disabled by ACPI
[ 1047.029854] ohci-pci 0000:00:13.1: System wakeup disabled by ACPI
[ 1047.044225] ehci-pci 0000:00:13.2: System wakeup disabled by ACPI
[ 1047.044489] PM: noirq resume of devices complete after 14.901 msecs
[ 1047.044949] PM: early resume of devices complete after 0.420 msecs
[ 1047.045430] [drm] AGP mode requested: 8
[ 1047.045439] agpgart-ati 0000:00:00.0: AGP 3.0 bridge
[ 1047.045460] agpgart-ati 0000:00:00.0: putting AGP V3 device into 8x mode
[ 1047.045495] radeon 0000:01:05.0: putting AGP V3 device into 8x mode
[ 1047.045545] radeon 0000:01:05.0: GTT: 32M 0xD2000000 - 0xD3FFFFFF
[ 1047.049858] sd 0:0:0:0: [sda] Starting disk
[ 1047.056122] radeon 0000:01:05.0: WB disabled
[ 1047.056131] radeon 0000:01:05.0: fence driver on ring 0 use gpu addr 0x00000000d2000000 and cpu addr 0xf8428000
[ 1047.056199] [drm] radeon: ring at 0x00000000D2001000
[ 1047.056250] [drm] ring test succeeded in 0 usecs
[ 1047.056268] [drm] ib test succeeded in 0 usecs
[ 1047.076150] rtc_cmos 00:00: System wakeup disabled by ACPI
[ 1047.076248] ACPI Error: No handler for Region [ECR_] (f6434960) [EmbeddedControl] (20150930/evregion-163)
[ 1047.076256] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20150930/exfldio-297)
[ 1047.076275] ACPI Error: Method parse/execution failed [\_SB.EPWR.PCLK] (Node f6488858), AE_NOT_EXIST (20150930/psparse-542)
[ 1047.076295] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPC0.EC0._Q1E] (Node f648e930), AE_NOT_EXIST (20150930/psparse-542)
[ 1047.104061] usb usb3: root hub lost power or was reset
[ 1047.108091] usb usb2: root hub lost power or was reset
[ 1047.273139] ata2.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[ 1047.273147] ata2.00: ACPI cmd ef/03:42:00:00:00:a0 (SET FEATURES) filtered out
[ 1047.288677] ata2.00: configured for UDMA/33
[ 1047.392181] PM: resume of devices complete after 347.217 msecs
[ 1047.393619] PM: Finishing wakeup.
[ 1047.393622] Restarting tasks ... done.
[ 1075.800446] PM: Syncing filesystems ... done.
[ 1076.445031] PM: Preparing system for sleep (mem)
[ 1076.445281] Freezing user space processes ... (elapsed 0.002 seconds) done.
[ 1076.448090] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[ 1076.449524] PM: Suspending system (mem)
[ 1076.449556] Suspending console(s) (use no_console_suspend to debug)
[ 1076.449985] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[ 1076.568319] sd 0:0:0:0: [sda] Stopping disk
[ 1076.964074] PM: suspend of devices complete after 514.226 msecs
[ 1076.964645] PM: late suspend of devices complete after 0.564 msecs
[ 1076.965284] ehci-pci 0000:00:13.2: System wakeup enabled by ACPI
[ 1076.965287] ohci-pci 0000:00:13.1: System wakeup enabled by ACPI
[ 1076.965331] ohci-pci 0000:00:13.0: System wakeup enabled by ACPI
[ 1076.980131] PM: noirq suspend of devices complete after 15.480 msecs
[ 1076.980297] ACPI: Preparing to enter system sleep state S3
[ 1076.981428] ACPI : EC: EC stopped
[ 1076.981430] PM: Saving platform NVS memory
[ 1076.981503] Disabling non-boot CPUs ...
[ 1076.981874] Broke affinity for irq 1
[ 1076.981880] Broke affinity for irq 9
[ 1076.981884] Broke affinity for irq 12
[ 1076.981887] Broke affinity for irq 14
[ 1076.981889] Broke affinity for irq 15
[ 1076.981893] Broke affinity for irq 16
[ 1076.981896] Broke affinity for irq 17
[ 1076.981900] Broke affinity for irq 18
[ 1076.981903] Broke affinity for irq 19
[ 1076.983098] smpboot: CPU 1 is now offline
[ 1076.992365] ACPI: Low-level resume complete
[ 1076.992365] ACPI : EC: EC started
[ 1076.992365] PM: Restoring platform NVS memory
[ 1076.992365] Enabling non-boot CPUs ...
[ 1077.012654] x86: Booting SMP configuration:
[ 1077.012657] smpboot: Booting Node 0 Processor 1 APIC 0x1
[ 1076.982929] Initializing CPU#1
[ 1077.026510]  cache: parent cpu1 should not be sleeping
[ 1077.027030] CPU1 is up
[ 1077.028623] ACPI: Waking up from system sleep state S3
[ 1077.029656] ohci-pci 0000:00:13.0: System wakeup disabled by ACPI
[ 1077.029709] ohci-pci 0000:00:13.1: System wakeup disabled by ACPI
[ 1077.044265] ehci-pci 0000:00:13.2: System wakeup disabled by ACPI
[ 1077.044506] PM: noirq resume of devices complete after 15.062 msecs
[ 1077.044962] PM: early resume of devices complete after 0.415 msecs
[ 1077.045429] [drm] AGP mode requested: 8
[ 1077.045438] agpgart-ati 0000:00:00.0: AGP 3.0 bridge
[ 1077.045460] agpgart-ati 0000:00:00.0: putting AGP V3 device into 8x mode
[ 1077.045494] radeon 0000:01:05.0: putting AGP V3 device into 8x mode
[ 1077.045544] radeon 0000:01:05.0: GTT: 32M 0xD2000000 - 0xD3FFFFFF
[ 1077.049859] sd 0:0:0:0: [sda] Starting disk
[ 1077.056092] radeon 0000:01:05.0: WB disabled
[ 1077.056101] radeon 0000:01:05.0: fence driver on ring 0 use gpu addr 0x00000000d2000000 and cpu addr 0xf8428000
[ 1077.056151] [drm] radeon: ring at 0x00000000D2001000
[ 1077.056194] [drm] ring test succeeded in 0 usecs
[ 1077.056214] [drm] ib test succeeded in 0 usecs
[ 1077.076155] rtc_cmos 00:00: System wakeup disabled by ACPI
[ 1077.104062] usb usb3: root hub lost power or was reset
[ 1077.108092] usb usb2: root hub lost power or was reset
[ 1077.137214] ACPI Error: No handler for Region [ECR_] (f6434960) [EmbeddedControl] (20150930/evregion-163)
[ 1077.137220] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20150930/exfldio-297)
[ 1077.137236] ACPI Error: Method parse/execution failed [\_SB.EPWR.PCLK] (Node f6488858), AE_NOT_EXIST (20150930/psparse-542)
[ 1077.137250] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPC0.EC0._Q1E] (Node f648e930), AE_NOT_EXIST (20150930/psparse-542)
[ 1077.273103] ata2.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[ 1077.273109] ata2.00: ACPI cmd ef/03:42:00:00:00:a0 (SET FEATURES) filtered out
[ 1077.288644] ata2.00: configured for UDMA/33
[ 1077.392243] PM: resume of devices complete after 347.267 msecs
[ 1077.392736] PM: Finishing wakeup.
[ 1077.392741] Restarting tasks ... done.
[ 1077.608070] firewire_core 0000:02:00.0: rediscovered device fw0
[ 1078.224382] ata1.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[ 1078.224395] ata1.00: ACPI cmd ef/03:45:00:00:00:a0 (SET FEATURES) filtered out
[ 1078.232441] ata1.00: configured for UDMA/100
[ 1078.354863] IPv6: ADDRCONF(NETDEV_UP): enp2s3: link is not ready
[ 1078.355181] 8139too 0000:02:03.0 enp2s3: link down
[ 1078.356347] IPv6: ADDRCONF(NETDEV_UP): enp2s3: link is not ready
[ 1078.363688] IPv6: ADDRCONF(NETDEV_UP): wlp2s2: link is not ready
[ 1078.380653] IPv6: ADDRCONF(NETDEV_UP): wlp2s2: link is not ready
[ 1078.491391] IPv6: ADDRCONF(NETDEV_UP): wlp2s2: link is not ready
[ 1106.025577] PM: Syncing filesystems ... done.
[ 1106.687382] PM: Preparing system for sleep (mem)
[ 1106.687634] Freezing user space processes ... (elapsed 0.002 seconds) done.
[ 1106.690456] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[ 1106.691908] PM: Suspending system (mem)
[ 1106.691942] Suspending console(s) (use no_console_suspend to debug)
[ 1106.692425] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[ 1106.854914] sd 0:0:0:0: [sda] Stopping disk
[ 1107.244443] PM: suspend of devices complete after 552.160 msecs
[ 1107.244985] PM: late suspend of devices complete after 0.535 msecs
[ 1107.245644] ohci-pci 0000:00:13.1: System wakeup enabled by ACPI
[ 1107.245647] ehci-pci 0000:00:13.2: System wakeup enabled by ACPI
[ 1107.245676] ohci-pci 0000:00:13.0: System wakeup enabled by ACPI
[ 1107.260122] PM: noirq suspend of devices complete after 15.131 msecs
[ 1107.260287] ACPI: Preparing to enter system sleep state S3
[ 1107.261420] ACPI : EC: EC stopped
[ 1107.261423] PM: Saving platform NVS memory
[ 1107.261505] Disabling non-boot CPUs ...
[ 1107.261878] Broke affinity for irq 1
[ 1107.261884] Broke affinity for irq 9
[ 1107.261888] Broke affinity for irq 12
[ 1107.261891] Broke affinity for irq 14
[ 1107.261894] Broke affinity for irq 15
[ 1107.261897] Broke affinity for irq 16
[ 1107.261900] Broke affinity for irq 17
[ 1107.261904] Broke affinity for irq 18
[ 1107.261907] Broke affinity for irq 19
[ 1107.263102] smpboot: CPU 1 is now offline
[ 1107.272362] ACPI: Low-level resume complete
[ 1107.272362] ACPI : EC: EC started
[ 1107.272362] PM: Restoring platform NVS memory
[ 1107.272362] Enabling non-boot CPUs ...
[ 1107.292650] x86: Booting SMP configuration:
[ 1107.292653] smpboot: Booting Node 0 Processor 1 APIC 0x1
[ 1107.262934] Initializing CPU#1
[ 1107.306573]  cache: parent cpu1 should not be sleeping
[ 1107.307089] CPU1 is up
[ 1107.308680] ACPI: Waking up from system sleep state S3
[ 1107.309713] ohci-pci 0000:00:13.0: System wakeup disabled by ACPI
[ 1107.309764] ohci-pci 0000:00:13.1: System wakeup disabled by ACPI
[ 1107.324263] ehci-pci 0000:00:13.2: System wakeup disabled by ACPI
[ 1107.324463] PM: noirq resume of devices complete after 14.962 msecs
[ 1107.324923] PM: early resume of devices complete after 0.420 msecs
[ 1107.329288] [drm] AGP mode requested: 8
[ 1107.329297] agpgart-ati 0000:00:00.0: AGP 3.0 bridge
[ 1107.329320] agpgart-ati 0000:00:00.0: putting AGP V3 device into 8x mode
[ 1107.329355] radeon 0000:01:05.0: putting AGP V3 device into 8x mode
[ 1107.329408] radeon 0000:01:05.0: GTT: 32M 0xD2000000 - 0xD3FFFFFF
[ 1107.330217] sd 0:0:0:0: [sda] Starting disk
[ 1107.340572] radeon 0000:01:05.0: WB disabled
[ 1107.340581] radeon 0000:01:05.0: fence driver on ring 0 use gpu addr 0x00000000d2000000 and cpu addr 0xf8428000
[ 1107.340649] [drm] radeon: ring at 0x00000000D2001000
[ 1107.340777] [drm] ring test succeeded in 0 usecs
[ 1107.340795] [drm] ib test succeeded in 0 usecs
[ 1107.360696] ACPI Error: No handler for Region [ECR_] (f6434960) [EmbeddedControl] (20150930/evregion-163)
[ 1107.360701] ACPI Error: Region EmbeddedControl (ID=3) has no handler (20150930/exfldio-297)
[ 1107.360719] ACPI Error: Method parse/execution failed [\_SB.EPWR.PCLK] (Node f6488858), AE_NOT_EXIST (20150930/psparse-542)
[ 1107.360733] ACPI Error: Method parse/execution failed [\_SB.PCI0.LPC0.EC0._Q1E] (Node f648e930), AE_NOT_EXIST (20150930/psparse-542)
[ 1107.364161] rtc_cmos 00:00: System wakeup disabled by ACPI
[ 1107.384062] usb usb3: root hub lost power or was reset
[ 1107.388091] usb usb2: root hub lost power or was reset
[ 1107.553149] ata2.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[ 1107.553155] ata2.00: ACPI cmd ef/03:42:00:00:00:a0 (SET FEATURES) filtered out
[ 1107.568678] ata2.00: configured for UDMA/33
[ 1107.672334] PM: resume of devices complete after 347.395 msecs
[ 1107.673318] PM: Finishing wakeup.
[ 1107.673321] Restarting tasks ... done.
[ 1107.920090] firewire_core 0000:02:00.0: rediscovered device fw0
[ 1108.504383] ata1.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[ 1108.504397] ata1.00: ACPI cmd ef/03:45:00:00:00:a0 (SET FEATURES) filtered out
  • Please check your settings in System Settings > Power Manager. If the settings are ok, enable System Tray Icon, right-click the icon and enable Presentation Mode and check if this helps. – mook765 Feb 18 '17 at 5:24
  • @mook765 I resolved the problem a different way... but thank you for your insight! – user595510 Feb 18 '17 at 10:45
1

To give credit where it is due: I found the solution on the Ubuntu MATE and Arch Linux forums.

Here's the baseline: it appears that systemd is causing our systems to suspend. I have no idea why, or if it will be fixed. But at the moment here is the solution:

  1. Before doing anything else, you can try to run systemd-inhibit from inside the GUI to prevent the suspends, but this doesn't always work.
  2. In a text editor (with root), open /etc/systemd/logind.conf
  3. Find the HandleLidSwitch option and change it from suspend to ignore.

    NOTE: I'm not sure if you will have to add this option or uncomment it, you'll have to try it and see what happens.

  4. Reboot the computer, and the problem should be resolved.

What this does is force systemd to ignore the "lid switch" (in quotes because it isn't a broken switch, but rather seemingly a bug in systemd). That might prevent suspending through the lid, but I never use that feature anyway and always prefer to suspend with the power button or menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy