The following used to work and now it doesn't:
apt-get install r-base=3.3.1-1trusty0 r-base-dev=3.3.1-1trusty0 r-recommended=3.3.1-1trusty0 r-base-core=3.3.1-1trusty0 Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: r-recommended : Depends: r-cran-mgcv (>= 1.1.5) but it is not going to be installed Depends: r-cran-nlme (>= 3.1.52) but it is not going to be installed E: Unable to correct problems, you have held broken packages.
If I remove the versions (e.g. 3.3.1-1trusty0), apt-get install works with no errors.
This answer notes that when specifying versions, "you may need to do some dependency resolution on your own".
Why does dependency resolution fail when the version is specified? What is the likely explanation of why apt-get install succeeded with no dependency errors with this same command (using these versions) about a month ago?