1

Today my laptop suddenly showed me this text at booting:

mount: mounting /dev/dm-0 on /root failed: No such device
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory
Target filesystem doesn't have requested /sbin/init.
No init found. Try passing init= bootarg.

BusyBox v1.21.1 (Ubuntu 1:1.21.0-1ubuntu1) built-in shell (ash)
...

i booted from livecd and checked all filesystems (there are three lvm volumes local-root, local-home and local-swap also there is /boot partition at /dev/sda1 that is not in lvm) with fsck

Same result after restarting..

Then while mounting my volumes for chrooting to them i saw that local-root can't be mounted with this reason:

# mount /dev/mapper/local-root /mnt
mount: unknown filesystem type 'silicon_medley_raid_member'

Darn! WHY?! why ME and NOW?!!

i've checked this twice:

# blkid /dev/mapper/local-root
/dev/mapper/local-root: TYPE="silicon_medley_raid_member"

However, i still can easily mount it with manually defined fstype:

# mount -t ext4 /dev/mapper/local-root /mnt 

But i don't know what to do next, how to change FSTYPE back to ext4 without loosing data? (yeah, i have a backup, but only for 'local-home' volume, and i don't want to reinstall full system rght now..)

Thanks for your time!

1

I had a lot of fun with the same bug today and can't count all the filesystem checks, boot-repairs, grub-reinstalls, ...

It turns out the solution is quite easy. Just extend your root volgroup by a few bytes and the type will be fixed to ext4 automatically.

lvextend -L +512B /dev/mapper/local-root

I found the solution here: https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/1011007

  • Thanks Nils! Unfortunately can't check this solution coz i've already reinstalled system, but i'll mark it as accepted – esergion Feb 19 '17 at 11:47
0

I ran into a similar problem. However, my LVM volume group was full so I couldn't try the hack mentioned in the other solution.

Instead I used wipefs to see that my partition actually had 2 signatures. One was correct (ext4). The other was incorrect (silicon_medley_raid_member).


First I booted with a LiveUSB that matched my version of Ubuntu (14.04). Then I ran this to see the two signatures:

sudo wipefs -n /dev/mapper/local-root

The output looked something like this:

offset               type
----------------------------------------------------------------
0x4444               ext4   [filesystem]
                     LABEL: root
                     UUID:  <redacted>

0xfffffff            silicon_medley_raid_member (raid)

(Offsets changed to protect the innocent.)

Then I ran this to test removing the bad signature.

sudo wipefs -n -o 0xfffffff /dev/mapper/local-root

Where 0xfffffff is the offset listed from the first command.

Finally I ran it again without -n to actually write the change to disk.

sudo wipefs -o <offset> /dev/mapper/local-root

And now blkid /dev/mapper/local-root showed the TYPE as ext4.


Be very careful when using wipefs. You should have a backup before doing it. And certainly don't use this method if you don't actually see two signatures.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.