While installing libgtk2.0-dev i'm receiving following error:
Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: libgtk2.0-dev : Depends: libglib2.0-dev (>= 2.27.3) but it is not going to be installed Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed Depends: libatk1.0-dev (>= 1.29.2) but it is not going to be installed Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed E: Unable to correct problems, you have held broken packages.
I tried lots of things like -f flag, synaptic, install them individually , install all dependency at once but everything failed.
Is libgtk2.0-dev is not supported on ubuntu 16.04 ?
apt-cache policy libgtk2.0-dev libglib2.0-dev
libgtk2.0-dev: Installed: (none) Candidate: 2.24.30-1ubuntu1 Version table: 2.24.30-1ubuntu1 500 500 http://mirror.dhakacom.com/ubuntu-archive xenial/main amd64 Packages libglib2.0-dev: Installed: (none) Candidate: 2.48.0-1ubuntu4 Version table: 2.48.0-1ubuntu4 500 500 http://mirror.dhakacom.com/ubuntu-archive xenial/main amd64 Packages