4

When I boot my laptop (HP Spectre x360, late 2016 version, running Ubuntu 16.10) with a Logitech receiver plugged in, grub hangs with the countdown stuck at 10s. Pressing keys on the keyboard doesn't do anything. I have to hard reset the computer and unplug the receiver before it works.

I tried switching the usb to other ports as suggested here, but that didn't work. I also tried changing the boot order in BIOS, enabling/disabling legacy usb, but none of that worked.

Before installing Ubuntu, the laptop booted fine (with the usb plugged in) on Windows 10. This also isn't an issue on my other laptop using the same receiver.

Is there some fix for this issue or alternatively would it be possible to disable usb while grub is loading?

  • Just a comment to say I have Logitech Unifying Receiver with K-800 backlit keyboard and MX Pro Mouse and never had a problem with BIOS or Grub at boot time, nor Ubuntu after booting. Everything worked out of the box with no need to install drivers. – WinEunuuchs2Unix Feb 17 '17 at 0:09
2

You might try upgrading the firmware in the Logitech unifying dongles. See https://community.logitech.com/s/question/0D531000055gw8YCAQ/logitech-response-to-unifying-receiver-research-findings for instructions and the firmware.

You might also check the USB settings in your BIOS. They may need to be set to USB 2.0, or legacy.

Lastly, you might have to plug the dongle directly into your computer's USB port, instead of a hub (if you're using one).

Update #1:

new link is https://community.logitech.com/s/question/0D531000058b3B7CAI/logitech-response-to-research-findings

| improve this answer | |
  • 1
    Thanks, after updating the firmware and enabling legacy mode again it worked. – daladier Feb 17 '17 at 22:35
  • @daladier how exactly did you enable "legacy mode". Is this an option in the BIOS? Using HP Spectre (purchased June 2018), Logitech MX Anywhere 2S, Ubuntu 18.04. Having problem identical to what is described above. Thanks – Sam Anthony Jun 11 '18 at 11:17
  • 2
    @daladier Solved my problem also by enabling "Legacy support" in the BIOS. In my BIOS I did this via System Configuration -> Boot Options -> Legacy Support -> Enabled – Sam Anthony Jun 11 '18 at 11:30
  • The post on the logitech forum got deleted. Anybody know of another resource to do this? – Andrew Roth Aug 12 '18 at 13:18
  • @AndrewRoth see the update to my answer. – heynnema Aug 12 '18 at 13:44
0

Yes updating the logitech firmware doesnt work. no option to change to legacy mode in my HP ENVY X360 laptop 2020 laptop. What worked for me is pressing esc and going startup menu(not bios) and selecting boot menu from there works.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.