0

Hardware:

  • laptop - ASUS x556uq-dm302d
  • projector - Acer X127H

OS:

  • Ubuntu 16.04 64bit

I tried to connect a projector as my second monitor, but it was not recognized: "No signal" and HDMI icon is shown on right bottom.

xrandr:

➜  ~ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
eDP-1-1 connected primary 1920x1080+0+0 344mm x 193mm
  1920x1080     60.05*+  59.93  
  1680x1050     59.95    59.88  
  1600x1024     60.17  
  1400x1050     59.98  
  1280x1024     60.02  
  1440x900      59.89  
  1280x960      60.00  
  1360x768      59.80    59.96  
  1152x864      60.00  
  1024x768      60.04    60.00  
  960x720       60.00  
  928x696       60.05  
  896x672       60.01  
  960x600       60.00  
  960x540       59.99  
  800x600       60.00    60.32    56.25  
  840x525       60.01    59.88  
  800x512       60.17  
  700x525       59.98  
  640x512       60.02  
  720x450       59.89  
  640x480       60.00    59.94  
  680x384       59.80    59.96  
  576x432       60.06  
  512x384       60.00  
  400x300       60.32    56.34  
  320x240       60.05  
DP-1-1 disconnected
HDMI-1-1 disconnected
HDMI-1-2 disconnected

sudo lshw -C display

*-display               
   description: VGA compatible controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 07
   width: 64 bits
   clock: 33MHz
   capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:128 memory:dd000000-ddffffff memory:b0000000-bfffffff ioport:f000(size=64)
*-display
   description: 3D controller
   product: GM108M [GeForce 940MX]
   vendor: NVIDIA Corporation
   physical id: 0
   bus info: pci@0000:01:00.0
   version: a2
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list rom
   configuration: driver=nvidia latency=0
   resources: irq:131 memory:de000000-deffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:e000(size=128) memory:df000000-df07ffff

Already tried this (installing Kernel 4.4), this (E: Unable to locate package nvidia-364)

  • Welcome to Ask Ubuntu! Did you by any chance try reseating/replacing the HDMI cable? Please edit your post to include the output of sudo lshw -C display which will tell us about both the video chipset and the driver in use. Thank you for helping us help you! – Elder Geek Feb 16 '17 at 21:30
  • yes, i tried removing and inserting HDMI cable several times. updated my question – iVenGO Feb 16 '17 at 21:51
  • 1
    Many people have found this useful. There are a couple other answers there as well. Let us know if those don't resolve your issue and we will dig a bit deeper. Note: available packages are found here. I think 364 is a typo or obsolete... – Elder Geek Feb 16 '17 at 22:07

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.