28

When I open a document sent to me by a colleague Calibri seems to work font as expected with the document:

enter image description here

But when I create a document on the same computer the Calibri font isn't available in the drop-down.

6
  • Where on the file system is the Calibri font located? Commented Feb 16, 2017 at 14:39
  • @GunnarHjalmarsson I'm not exactly sure any suggestions on how I can find out? Commented Feb 16, 2017 at 14:39
  • How did you install it? Commented Feb 16, 2017 at 14:40
  • Possibly you need to install the ttf-mscorefonts-installer package (which includes Calibri). If you do, you'd better install the Debian version in accordance with this answer. Commented Feb 16, 2017 at 14:47
  • 2
    @GunnarHjalmarsson, I'm pretty certain that the ttf-mscorefonts-installer package does NOT include Calibri...
    – Digger
    Commented Jul 24, 2018 at 3:39

7 Answers 7

46

You have to install it:

  1. Install Microsoft's classic TrueType fonts: sudo apt install ttf-mscorefonts-installer

  2. Install Microsoft's newer ClearType fonts:

    • which includes: Constantia, Corbel, Calibri, Cambria, Candara, and Consolas
    • make fonts directory: mkdir ~/.fonts
    • wget -qO- http://plasmasturm.org/code/vistafonts-installer/vistafonts-installer | bash

  3. Then close and open LibreOffice, if open while you installed these fonts.

Source:

http://www.pcworld.com/article/2863497/how-to-install-microsoft-fonts-in-linux-office-suites.html

7
14

The image that you've included with your question shows that the name of the font is in italics. This means that the named font is not installed, and an automatically selected substitute has been used instead. If you hover the cursor over this italicised font name you may see a comment to this effect.

If you don't wish to install the missing font, you can edit the Style to specify a font that is installed (right-click within a paragraph, and choose 'Edit Paragraph Style...' from the bottom of the dropdown menu).

In Microsoft Office the same thing happens with missing fonts, but there's usually no indication that a font substitution has occurred.

8

I had the same problem a week ago. ttf-mscorefonts-installer doesn't include Calibri.

It includes the following fonts:

  • Andale Mono
  • Arial Black
  • Arial (Bold, Italic, Bold Italic)
  • Comic Sans MS (Bold)
  • Courier New (Bold, Italic, Bold Italic)
  • Georgia (Bold, Italic, Bold Italic)
  • Impact
  • Times New Roman (Bold, Italic, Bold Italic)
  • Trebuchet (Bold, Italic, Bold Italic)
  • Verdana (Bold, Italic, Bold Italic)
  • Webdings

Source: sudo apt show ttf-mscorefonts-installer

If you own a legit Microsoft Office license you could copy calibri.ttf and all calibri*.ttf files (bold, italics, ...) from C:\Windows\Fonts and install them on Ubuntu by simply double clicking them. Although I'm not sure if that's according to Office's terms of service.

1
  • How to install this in Mac system?
    – Bogaso
    Commented Jun 25, 2021 at 18:31
7

The fonts Calibri, Cambria, Candara, Consolas, Constantia and Corbel require a Microsoft Office license, which means that they are only legal on machines where Microsoft Office (available only on Windows and MacOS) is installed.

LibreOffice installs the free font Carlito, which is a replacement for Calibri, and Caladea, which is a replacement for Cambria.

3
  • 4
    My system (Lubuntu 16.04) does have LibreOffice installed, but neither of the fonts Carlito nor Caladea are installed. What system/version are you using?
    – zrajm
    Commented Apr 29, 2018 at 12:22
  • 2
    In Ubuntu 19.04, you can install them with apt. Carlito is in package fonts-crosextra-carlito and Caladea is in fonts-crosextra-caladea. Commented Jan 30, 2020 at 10:49
  • 2
    these fonts are legal on any system with powerpoint viewer 2007 (regardless of the fact that a linux system may not be able to run it). so it's legal to use them to display files using these fonts on linux in libreoffice & co. However, to create documents with these fonts legally, you must have an appropriate licence to these fonts (for instance office365-licence).
    – bernstein
    Commented Dec 11, 2020 at 14:49
5

Here is a nice way of installing Calibri on your Debian based system.
Run this command in the terminal.

$ sudo apt-get install fontforge

This will install Font Forge on your system, which will help in font conversion. After running the above command, execute the command given bellow:

$ wget https://gist.github.com/maxwelleite/10774746/raw/ttf-vista-fonts-installer.sh -q -O - | sudo bash

This will install the vista font pack on your system that also includes Calibri.

1
  • Thank god! Your solution works! Can't beleive I need to install Calibri for ClosedXML to work... smh Commented Apr 21, 2023 at 11:08
3

Another solution would be installing Carlito and Caladea fonts manually, and then manually map them in Tools->Options->Fonts so Calibri and Cambria are always shown as Carlito and Caladea respectively. I think LO 6 does that by default, but in older versions that didn't ship Carlito/Caladea it may be necessary doing it manually.

1

You can install "Calibri" and additional fonts using fontist.

Install Ruby development files:

sudo apt-get install ruby-dev

Install fontist:

sudo gem install fontist

Update fontist list:

fontist update

Install Calibri font:

fontist install "Calibri"

Fontist will present you the Microsoft's EULA: please read it and type "yes" followed by enter if you accept it.

Fontist will download the fonts and tell you where the fonts have been installed, in my case it was: $HOME/.fontist/fonts/CALIBRI.TTF

LibreOffice uses fontconfig to resolve fonts: fontconfig needs to be aware of the new fonts if you want LibreOffice to use them. Create a local fontconfig configuration file, and add the directory in which the fonts have been installed:

mkdir $HOME/.config/fontconfig
mkdir $HOME/.config/fontconfig/conf.d
export CONFFILE=${HOME}/.config/fontconfig/conf.d/10-fontist.conf
echo "<?xml version='1.0'?>" >>  $CONFFILE
echo "<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>" >> $CONFFILE
echo "<fontconfig>" >>  $CONFFILE
echo "<dir>$HOME/.fontist/fonts</dir>" >> $CONFFILE
echo "</fontconfig>" >> $CONFFILE

Update fontconfig's cache:

fc-cache -f

Check that the font "Calibri" is resolved by fontconfig into the new installed font:

fc-match "Calibri"

If everything went right, the output of the previous command should be something like:

CALIBRI.TTF: "Calibri" "Regular"

Now LibreOffice will use the newly installed fonts. You can check this is true if LibreOffice does not display the font name in italics anymore.

1
  • If you have already read Microsoft's EULA in the past and you don't need to read it again, use yes "yes" | fontist install "Calibri" to accept Microsoft's EULA automatically. Commented Dec 17, 2020 at 5:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .