4

I just installed Ubuntu 16.04. Ubuntu Software Center is being weird. It's just waaaaay too slow. Takes ages to "load" something. It doesn't even work sometimes. Maybe it does, but i can't wait 10 minutes, so i just close it. I mean, i click on "Updates", and it just won't load. Sometimes it will, but it takes a long time. What's up with that? I'm a total "noob" and this is the first time i'm trying a Linux based OS, so be gentle :P. I've googled it, but no real solution popped out.

  • You should use the Updates tool (search for it in dash) in order to apply all the available updates -or- in terminal do sudo apt update && sudo apt full-upgrade before using the "app store". The main reason why it feels "slow" right now is probably because it's checking for updates in the background already. – user589808 Feb 16 '17 at 11:04
4

Software Center which comes bundled with ubuntu 16.04 is very buggy, and is better to avoid it as much as possible.

You can use Synaptic Package Manager instead which is miles ahead of the default one.

sudo apt-get install synaptic

Other than that, try sticking with the terminal for your basic software installation (just google ubuntu {desired software} ).

To update system, run

sudo apt-get update && sudo apt-get upgrade
  • Ubuntu Software was buggy for me in 16.04 too, however since I upgraded this OS from 16.04 to 18.04 there haven't been any more bugs in it and Ubuntu Software takes about 1 second to open in 18.04. I miss the way the old Ubuntu Software Center searched for software, so I installed Synaptic alongside Ubuntu Software so that I could use Synaptic's old-fashioned search functionality. – karel Sep 15 '18 at 8:34
1

I'm experiencing the same behavior. I found that in every case where I'm seeing Ubuntu Software Center spin its wheels, minimizing then restoring the window causes the expected content to be displayed immediately. It works, but I have to perform these acrobatics every time I click something new.

  • Release: 16.04.2 LTS (Xenial Xerus) 64-bit (fully patched)
  • Kernel: Linux 4.4.0-66-generic x86_64
  • MATE: 1.12.1
  • Memory: 15.7 GiB
  • Processor: Intel® Core™ i7 CPU X 990 @ 3.47GHz × 12
1

Change the server option in the Software and Update window and
click on 'select best server' like in this image:

enter image description here

It worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.