2

I messed up Ubuntu 16.04 so package manager would not allow new updates to packages, so I re-installed 16.04 over the bad 16.04, my laptop has Win 7 also as dual boot.

Every time I now install from Terminal or Ubuntu Software, it installs version 17. I do not like 17 have not learned how to install addons, icons, particularly EXODUS, PHOENIX, SALTS TRAKT TV etc. Can not seem to install anything in 17. 16.1 is easy.

Can do all I want in older KODI 16.1 Googled how to install 16.1 on ubuntu. All links install version 17 for Ubuntu. Windows, you can easily install Kodi 16.1. I prefer Ubuntu 16.04 but want to install Kodi 16.1, not 17.

PLEASE HELP ME, I am relatively bad with terminal and those commands. I can copy and paste into Terminal using sudo, etc.

3

Kodi 17 has just been released. There are many things to iron out, others to improve and, of course, icons/themes and other eye-candy as well as many addons will need to be updated for the new version. This should be expected for any new major version.

That said, installing the old version, Kodi 16.1 is easy. However, you need to uninstall Kodi and remove the stable PPA before installing the 16.1 version.

sudo apt install ppa-purge
sudo ppa-purge ppa:team-xbmc/ppa

Now add the PPA for the old version and install:

sudo apt-add-repository ppa:team-xbmc/kodi-old
sudo apt update
sudo apt install kodi
  • @Geof-Sprague says: I have run into 3 older machines that just can't handle Kodi 17. It runs, but so slow it's not an option to run it. These steps just install 17 now. How can you get 16.1 that I installed weeks ago when 17 was still in beta. I was able to get 16.1 (again on an older system with linux). It works great. Now a few weeks later and I can't get 16.1 on a linux machine. I've spent hours trying to find a way. I have the same slow functioning Kodi on this machine. – MadMike Feb 21 '17 at 8:02
1

I have found this command works pretty fine to install kodi 16.1 Jarvis on ubuntu 16.04.1. There is no need to purge any ppa just do this:

sudo add-apt-repository ppa:team-xbmc/kodi-old    
sudo apt-get update

sudo apt-get install kodi=2:16.1~git20160425.1001-final-0xenial kodi-bin=2:16.1~git20160425.1001-final-0xenial

that's all.

  • I will try your solution, it is very much appreciated. I WILL ADD A COMMENT AFTER. THANK YOU !!! – kye153 Mar 14 '17 at 0:27
0

Right direction but not working yet as my system doesn't recognized the 16.1 version of the xbmc package. So I had the idea of checking the package version in the Synaptic package Manager, enabling the old ppa.

After removing Kodi Krypton (17) I managed on Ubuntu Mate 16.04 to make a fresh install of Kodi Jarvis (16.1) simply by:

  1. removing the actual ppa
  2. enabling the old one (as mentioned on the Kodi wiki)
  3. install all the Kodi 16.1 packages using the Synaptic Package Manager

    Then an update to check that everything is there and now I'm trying to install the wookie build up from inside (using the add-on) as they (the Wookie community) keep a build up version for Jarvis.

0

I found a solution that loads the Kodi 17 version instead of 16.1 version.

From How To Install Previous Versions of Kodi (XBMC) in Ubuntu Linux:

To install previous versions of Kodi in Linux, you simply have to specify the version number when you execute the install command:

sudo apt-get install xbmc=2:[INSERT VERSION NUMBER HERE]* xbmc-bin=2:[INSERT VERSION NUMBER HERE]*

For Kodi versions (beyond 13.2), replace xbmc with kodi for both packages.

  • PPS:- in the article it says you have to replace the xbmc with kodi – Slippers Mar 10 '17 at 1:03
0

I managed to get the answer from mixing answers on this thread and another, here it is!

sudo add-apt-repository -r -y ppa:team-xbmc/ppa
sudo add-apt-repository -y ppa:team-xbmc/kodi-old
sudo apt-get update
sudo apt-get install kodi=2:16* kodi-bin=2:16*

How do I find and install Kodi 16.1 Jarvis package on Xubuntu 16.04?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.