0

My wireless internet is very unreliable, so I usually have to connect to the internet using a cable, but this is very inconvenient.

I tried doing the solution for what seems like a similar problem here, but it still does not fix the issue: 16.04 LTS wifi connection issues with Realtek RTL8723BE adapter ... That is, I created /etc/pm/config.d/config and added SUSPEND_MODULES="rtl8821ae"

$ lspci -knn | grep Net -A2
03:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821AE 802.11ac PCIe Wireless Network Adapter [10ec:8821]
    Subsystem: XAVi Technologies Corp. RTL8821AE 802.11ac PCIe Wireless Network Adapter [1b9a:2482]
    Kernel driver in use: rtl8821ae
    Kernel modules: rtl8821ae
  • The answers in the question you linked may work if - and only if - you have the same hardware. Please edit and add the result of lspci -knn | grep Net -A2. – user589808 Feb 15 '17 at 22:36
  • @CelticWarrior I have added the hardware information -- do you have any more suggestions? it looks like I have a different wireless network adapter, so I did change the 'suspend_modules' line accordingly, but it still doesn't fixed the problem – pwprnt Feb 16 '17 at 22:57
  • @CelticWarrior does anyone have a solution? – pwprnt Feb 23 '17 at 1:55
0

I had a similar issue with Ubuntu a few versions back, and it turned out to be the wireless adapter's power management. I am pretty sure this was fixed in 16.04, but you can check this link to see if it fixes your issue with WiFi:

ubuntu 14.04 wireless constantly disconnects

Hope this works for you too! :)

| improve this answer | |
  • this didn't work for me , any other suggestions welcome – pwprnt Feb 28 '17 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.